padulka
Hot Shot
Hot Shot

Horizon for linux - VDI errors

Jump to solution

Hi to all, I'm trying to deploy a Ubuntu VDI; all works fine, when I create a full-clone of a master template it takes the all network configuration from DHCP server and it can access to internet but horizon still remains in customizing status and I see the guest network status as screen attach. Any idea? Thanks

1 Solution

Accepted Solutions
padulka
Hot Shot
Hot Shot

I've solved my issue, I'm not sure it's the solution or a workaround but for me it works.

sudo vi /etc/NetworkManager/NetworkManager.conf

​change managed=false to managed=true

View solution in original post

6 Replies
lisarobert
Contributor
Contributor

I am facing same problem how to fix that ...reply me for further detail thanks in advance.

sjesse
Leadership
Leadership

Can you share any of the logs? If not take a look at the ones here,  and see if anything pops up

Horizon Agent installation directory /usr/lib/vmware/viewagent

Horizon Agent configuration /etc/vmware/viewagent-config.txt

Machine configuration /etc/vmware/viewagent-machine.cfg

do you have the vm joined to the domain?

0 Kudos
padulka
Hot Shot
Hot Shot

Hi sjesse,

Following:

  • Horizon Agent installation directory /usr/lib/vmware/viewagent - It's more big to upload all folder
  • Horizon Agent configuration /etc/vmware/viewagent-config.txt - In attach
  • Machine configuration /etc/vmware/viewagent-machine.cfg - In attach

Not at this moment I don't need to test this, after someone will help me to authenticate ubuntu VDI with openlad server.

I've already tried to change network adapter from vmxnet3 to e1000.

I've already tried to change from VMware tools to OpenVM-Tools.

Regards

0 Kudos
mchadwick19
Hot Shot
Hot Shot

I wonder if it's failing because it's trying to join to a domain, you said in your initial question that you have yet to figure that out and you are just trying to get the clones up and working.

Try setting OfflineJoinDomain = none in /etc/vmware/viewagent-custom.conf (please double check the syntax as I haven't worked on the Linux VDI side in about a year).

This is what is in the Instant Clone doc's for Horizon Linux Desktops here Create an Instant-Clone Floating Desktop Pool for Linux step #5, bullet 2. I wonder if this will bypass the domain join attempt.

VDI Engineer VCP-DCV, VCP7-DTM, VCAP7-DTM Design
0 Kudos
padulka
Hot Shot
Hot Shot

mchadwick19​ I try to change but my issue still remain.

I'm not using istant clone but full copy clone.

I'm trying with Open VM tools and VMware Tools but nothing change.

0 Kudos
padulka
Hot Shot
Hot Shot

I've solved my issue, I'm not sure it's the solution or a workaround but for me it works.

sudo vi /etc/NetworkManager/NetworkManager.conf

​change managed=false to managed=true

View solution in original post