solgaeDK
VMware Employee
VMware Employee

Horizon View Agent 6.0.2 Windows 8.1 Desktops - Adjusting screen size scale causes mouse pointer to be stuck in top-left corner

Jump to solution

Hello,

I'm having some issues when I try to adjust the size scaling option in Windows 8.1 virtual desktop with View agent 6.0.2. When I try to change the scaling thru Control Panel -> Display -> Change the size of all items option (the Toggle Display Settings Control option is disabled per VMware KB: Settings tab is not available in the display control panel of a Horizon View desktop in l...). After I do this, the mouse pointer suddenly gets locked to the top-left corner, and I'm unable to move the mouse pointer out of that corner as the mouse pointer keeps jumping itself back into it. When I change the scaling back to the original (using keyboard to change the setting), the mouse pointer behavior returns to normal.

Anyone else having this issue?

0 Kudos
1 Solution

Accepted Solutions
solgaeDK
VMware Employee
VMware Employee

Found the solution by adding a registry entry:

Location: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Teradici\PCoIP\pcoip_admin_defaults

Name: pcoip.disable_cursor_jumping

Type: REG_DWORD

Data: 1

After this is set on a parent image and recomposed (or reboot if you're setting this on a persistent desktop), there were no more mouse pointer jumps after changing the font/UI scale.

This was actually listed in KB here - not exactly the problem listed in KB, but it's similar enough:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=206070...

View solution in original post

0 Kudos
5 Replies
oturn
Enthusiast
Enthusiast

Yes! I could never find an answer or fix for this issue. However, I discovered that if I disconnected after logon, then immediately reconnected, the mouse was no longer stuck. Go figure.

Unfortunately, the same problem exists in Windows 10, and now the workaround doesn't help. Fortunately I found this experimental setting, which only works on the Horizon View 3.4 client:

KEY: HKCU\software\vmware, inc.\vmware vdm\client

Value: DWORD: EnableSessionDPIScaling 1

1 = on

0 = off

It does slightly reduce the resolution, but the scaling is finally correct, and most of all I can read the screen without a magnifying glass.

0 Kudos
glennvelsol
Enthusiast
Enthusiast

Just wanted to chime in that...that I enabled the group policy so we can edit the font size's and once i'm able to edit them... the second i hit apply, the mouse shoots up to the top left corner and screws everything up. If I disconnect and reconnect it's fine but that isn't acceptable to me.

0 Kudos
solgaeDK
VMware Employee
VMware Employee

Found the solution by adding a registry entry:

Location: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Teradici\PCoIP\pcoip_admin_defaults

Name: pcoip.disable_cursor_jumping

Type: REG_DWORD

Data: 1

After this is set on a parent image and recomposed (or reboot if you're setting this on a persistent desktop), there were no more mouse pointer jumps after changing the font/UI scale.

This was actually listed in KB here - not exactly the problem listed in KB, but it's similar enough:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=206070...

0 Kudos
glennvelsol
Enthusiast
Enthusiast

Awesome, thanks! I'll give this a try!

0 Kudos
Greg_Butler
Contributor
Contributor

Has anyone tried this on Windows 10 with any success? The below article says that the key should be in a different place. I tried adding the key in both places on the base image and ran into a situation where non admins were logged off immediately after logging in (random, I know). I plan to try one key at a time tomorrow.

https://www.linkedin.com/pulse/mouse-cursor-jumps-vmware-horizon-view-windows-10-desktop-butyrin

0 Kudos