Kilroy526
Contributor
Contributor

Horizon VIEW TEAMS Black Screen when screen sharing

Anyone seeing this issue?

VDI Desktop running Windows 10 21H2, Horizon VIEW 8 2111, TEAMS machine wide installer 1.5.0.21463, Teams is offloading.

When sharing a desktop screen, the person viewing the screen share will see a black screen when the sharer selects an application on the none shared screen  or just clicks on the screen not being shared.

Very high level.

User has two monitors, say 1 and 2.

User shares monitor 1

User is in monitor 1 moving around, this can be seen by the viewing person.

User opens an application, which opens on monitor 2 or just clicks on monitor 2, making monitor 2 the active monitor, the screen goes black to the viewer.

User clicks back on to monitor 1, the screen sharing resumes.

 

 

0 Kudos
25 Replies
Kilroy526
Contributor
Contributor

Update -  inside a session, set the following registry key to 0 = HKEY_LOCAL_MACHINE\SOFTWARE\Policies\VMware, Inc.\VMware WebRTCRedir  teamsEnabled 

 

Quit Teams and relaunched

Confirmed Teams was not running optimized.

Tested and no black screens

I suspect the local install of Webroot is blocking the off loading for Teams to the local workstation.

0 Kudos
hermanc01
Enthusiast
Enthusiast

We're seeing this exact same issue as well.  For us the workaround was to rollback the Windows client to version 2203.

0 Kudos
Sam0054
Enthusiast
Enthusiast

@Kilroy526 

What display protocol type are you using?

Try change the protocol type to VMware Blast Extreme on VMware Horizon Client settings if the current one is set to either PCoIP or Microsoft RDP.

 

Thanks

Sam

0 Kudos
hermanc01
Enthusiast
Enthusiast

We only use the Blast protocol.

0 Kudos
popvm
Hot Shot
Hot Shot

Looks like a known limitation? 

Teams for Virtualized Desktop Infrastructure - Microsoft Teams | Microsoft Docs 

The following are known issues and limitations for calling and meetings:

  • Outgoing screen sharing:
    • Application sharing is not supported for VMware and AVD/W365.
0 Kudos
ZacMcKracken
Contributor
Contributor

We have exactly the same problem. When we connect via the PCOIP protocol, sharing in teams works. When we connect with BLAST we have the problems with sharing and black screens. Could it be due to some GPO policy?

BR
Christoph

0 Kudos
moutar
Contributor
Contributor

Same issue in our environment using the 2206 Horizon client. Seems to be a bug in the client. Rolling back to 2203 fixes the issue but now we lose backgrounds. Anybody find any other fixes besides rolling back to 2203?

0 Kudos
FDST92
Contributor
Contributor

Same issue.. Any fix other than rollback version? we have more than 2000 computers with the 2206 release.

0 Kudos
jkorson97
Contributor
Contributor

If you have the 2206 client, Go to the settings, Calls and Sharing, and turn off media optimization for WebRTC Applications (See attachment). I believe this is the same setting as the registry key Kilroy526 changed.

This seemed to resolve the black screen issue for some of our users so far.

0 Kudos
FDST92
Contributor
Contributor

Thanks for your feedback.

We tried the settings but it seems to disable the whole Media Optimization and it's unfortunately not possible for us. We need to have the Optimization to reduce the ressources on the infrastructure. We have approx. 2800 VDI running every day so if we disable the Optimization I think the CPU ressources won't like it 🙂

0 Kudos
FDST92
Contributor
Contributor

After contacting VMware Support, they provided us a supported workaround.

PLEASE NOTE IT ONLY AFFECT HORIZON 2206 VERSION
(use this fix only if you're running this version)

Add the following registry key on the client side.

[HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\vmware html5mmr\webrtcRedir]
"html5mmr.webrtc.enableWinReadback"=dword:00000000

0 Kudos
LarryRix
Contributor
Contributor

Does the registry key get added to the client side or the VDI side?

0 Kudos
jkorson97
Contributor
Contributor

Just the client side.

FYI, there is a new version called 2209. This seemed to fix this issue where you don't need to add the registry key.

0 Kudos
LarryRix
Contributor
Contributor

Already tried the 2209 version and we still get the black screen. It seemed better but still goes black. 

0 Kudos
LarryRix
Contributor
Contributor

I don't see vmware html5mmr\webrtcRedir in my registry. Do I need to create both of those keys too. 

Tags (1)
0 Kudos
kli
VMware Employee
VMware Employee

Hi Kilroy526, this is a known issue with horizon client 2206 with horizon agent 2111 or 2203.  It is fixed in the latest Horizon Client, 2209.  Or please see https://kb.vmware.com/s/article/89741 for a workaround.

0 Kudos
RameshKashyap
Contributor
Contributor

It is a known issue. Refer to https://kb.vmware.com/s/article/89741

I was able to resolved by installing HV Agent 2209 on machines.

0 Kudos
skubik
Contributor
Contributor

Also having this problem with client 2209 Windows, video camera is intermittent, screen share from others appear black / not visible as if they're not sharing.  I am using BLAST with encoder switch enabled and vmware optimized teams x64 1.6.00.376  Thanks!

0 Kudos
jkorson97
Contributor
Contributor

Make sure these two setting are on in the snip below. If you change settings log off and log back into your remote desktop and test. If you still have black screen, check with your IT that manages Horizon. They might be controlling the policy. 

jkorson97_1-1673385435361.png

 

0 Kudos