chrischay
Contributor
Contributor

Horizon Client not working if accessing from public (internet) network

Hi All,

Hopefully someone can shed lights on this.

I'm trying to deploy a VDI and so far it's not working if users will access the virtual desktops from the internet. My configurations as follows.

Public DNS A Records:

view.myco.com     A     65.10.20.2

view.myco.com     A     208.10.20.2

Internal DNS A Records:

uag1.myco.com     A     192.168.10.2

uag2.myco.com     A     192.168.10.3

view.myco.com     A     192.168.10.8

My UAG's have two nics for Internet facing and Management/Internal Facing

UAG1 = eth0 is 10.10.20.1 (internet facing), 192.168.10.2 (internal/management)

UAG2 = eth0 is 10.10.20.2 (internet facing), 192.168.10.3 (internal/management)

The plan is that the users from public(internet) network will access their desktops using view.myco.com FQDN. The view.myco.com is having a forward lookup zones of

65.10.20.2 or 208.10.20.2. Then the 65.10.20.2 or 208.10.20.2 is then translated to the external Load Baancer IP of 10.10.20.3.

Here are my UAG's settings:

UAG1:

PCOIP External URL: 10.10.20.3

BLAST External URL: https://view.myco.com:443

Tunnel External URL: https://view.myco.com:443

UAG2:

PCOIP External URL: 10.10.20.3

BLAST External URL: https://view.myco.com:443

Tunnel External URL: https://view.myco.com:443

So far, accessing from internet is not working, but accessing the virtual desktops internally is working. So I'm wondering if my configurations is correct?

I attach my diagram for clarification.

Any inputs is greatly appreciated.

Thanks,

0 Kudos
1 Reply
mrkasius
Enthusiast
Enthusiast

Hi chrischay,

Normally your Public DNS A Records should be like this:

UAG1.myco.com     A     65.10.20.2

UAG2.myco.com     A     208.10.20.2

view.myco.com        A     xxx.xxx.xxx.xxx     (load balancer VIP)

Could you share more information about your load balancer?

0 Kudos