IamAshwin7
Enthusiast
Enthusiast

Horizon 7.2 version:Horizon agent service not starting automatically

Jump to solution

There are 2 OU's. In the OU with issue the virtual machines have Windows event log service(Disabled state) and the Horizon agent state(stopped state) are stopped. They can only be started by logging into the machines manually. In a test OU deployed with only default domain policies the machines have the Windows eventlog service in started state bu the Horizon Agent service is in stopped state. This can be rectified by either restarting the machines manually or through the Horizon UI. After being available state on the UI the vms with issue tend to be unstable with the availability status. Both machines(Machines with and without issue) are in agent unreachable status in the Horizon admin UI. Any solutions or known issues with 7.2 version.

0 Kudos
1 Solution

Accepted Solutions
IamAshwin7
Enthusiast
Enthusiast

Turned out to be a group policy blocking the Windows eventvwr service to start. This was resolved by editing the group policy to stop disabling the service.

View solution in original post

0 Kudos
3 Replies
IamAshwin7
Enthusiast
Enthusiast

Turned out to be a group policy blocking the Windows eventvwr service to start. This was resolved by editing the group policy to stop disabling the service.

View solution in original post

0 Kudos
WAlexvm
Contributor
Contributor

Hi IamAshwin7,

I have a same problem, but I didn't find a way to set  group policy to disable the Windows eventvwr service.

Cloud you provide the setting steps?

Thank you very much!

0 Kudos
Shreyskar
VMware Employee
VMware Employee

Method-1:

If you want to disable event viewer on machines, you can create a software restriction policy with Path rule to deny below path:

"%systemroot%\system32\eventvwr.exe" under computer configuration> policies> windows settings,> security settings >software restriction policy

This will disable event vwr on machine.

Method-2:

You can also disable event viewer from appearing in MMC by going to User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/permitted snap-ins\Event Viewer

0 Kudos