VMware Horizon Community
AbbedSedkaoui
Enthusiast
Enthusiast
Jump to solution

Handling error 1603 silently installed connection server VDM_IP_PROTOCOL_USAGE = ipv4

Hi, i got this error while doing silent install, here the log:

serverInstUtil: 07/07/23 10:06:38 Attempting to resolve localhost
serverInstUtil: 07/07/23 10:06:38 localhost IPv4 address is 127.0.0.1
serverInstUtil: 07/07/23 10:06:38 localhost IPv6 address is ::1
serverInstUtil: 07/07/23 10:06:38 vdmServerResolveHostName ERROR: Could not resolve localhost for IP mode ipv4
serverInstUtil: 07/07/23 10:06:38 Exiting custom action VMCheckOSPreReqs
CustomAction VM_CheckOSPreReqs returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Fin de l'action 10:06:38 : VM_CheckOSPreReqs. Valeur renvoyée 3.
Fin de l'action 10:06:38 : INSTALL. Valeur renvoyée 3.

Since the graphical install default to ipv4 without issue, maybe the logic in the installer vdmServerResolveHostName check can be more relaxed ?

Horizon connection server version 2303
Windows server 2022

ping confirm that localhost resolve to IPv6 address ::1
I found it is the case on Windows following RFC3484 which prefer ipv6 stack since Windows Vista and Windows Server 2008.

Reply
0 Kudos
1 Solution

Accepted Solutions
AbbedSedkaoui
Enthusiast
Enthusiast
Jump to solution

I didn't find any KB for this specific error so my workaround is to prefer IPv4 over IPV6 + ommit VDM_IP_PROTOCOL_USAGE = ipv4 or i still get this error.

https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/configure-ipv6-in-windows#u...

IPv6 Functionality Registry value and comments
Prefer IPv4 over IPv6 Decimal 32
Hexadecimal 0x20
Binary xx1x xxxx

Recommended instead of disabling IPv6.

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d 32 /f


That line added as an application before a restart in the tasksequence to deploy the Connection Server solved the issue (notice the 32 at the end).

Why did i choose ipv4 for Horizon connection server ?

Because i plan to setup trueSSO with Horizon Enrollment server that support only ipv4,

and also because Unified Access Gateway can handle dual ipv4 and ipv6 https://docs.vmware.com/en/VMware-Horizon/2303/horizon-installation/GUID-AE561E5A-786F-4BE5-AB63-1CD...

View solution in original post

Reply
0 Kudos
1 Reply
AbbedSedkaoui
Enthusiast
Enthusiast
Jump to solution

I didn't find any KB for this specific error so my workaround is to prefer IPv4 over IPV6 + ommit VDM_IP_PROTOCOL_USAGE = ipv4 or i still get this error.

https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/configure-ipv6-in-windows#u...

IPv6 Functionality Registry value and comments
Prefer IPv4 over IPv6 Decimal 32
Hexadecimal 0x20
Binary xx1x xxxx

Recommended instead of disabling IPv6.

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d 32 /f


That line added as an application before a restart in the tasksequence to deploy the Connection Server solved the issue (notice the 32 at the end).

Why did i choose ipv4 for Horizon connection server ?

Because i plan to setup trueSSO with Horizon Enrollment server that support only ipv4,

and also because Unified Access Gateway can handle dual ipv4 and ipv6 https://docs.vmware.com/en/VMware-Horizon/2303/horizon-installation/GUID-AE561E5A-786F-4BE5-AB63-1CD...

Reply
0 Kudos