Highlighted
Hot Shot
Hot Shot

Google Chrome on Horizon View Windows 10 desktops is very fuzzy

We are testing Windows 10 in our VDI environment where we use Horizon View 7.3.2 currently and we have noticed that Google Chrome is very fuzzy on Windows 10 desktops.  I've tried overriding the dpi scaling options and allowing the application, system or system (enhanced) to see if any of those fix the issue (which it does on my non-vdi Windows 10 desktops) but it doesn't seem to work within the Horizon View environment.  Does anyone have any suggestions or a fix for this in Horizon View?

12 Replies
Highlighted
Enthusiast
Enthusiast

Have you tired to manually give you master image more video ram. I'm sure you are not using a grid or 3d fx soultion

Try to upgrade the video ram to set to 2 monitors and over 80mb of video ram on the master image. Then recompose to the pool so all VM's get the change. See if that fixes the issue

I have noticed the machines like over 50mb of Video Ram per Vm to run the best the auto doesn't look well on some machines.

0 Kudos
Highlighted
VMware Employee
VMware Employee

yes you can enhance the video memory by adding another monitor with pool setting, and also you can do it with gold image setting by edit vedio card settings and increase the video memory size

in addition you can edit the chrome settings,

open chrome://flags (put this in the Chrome address bar and press Enter) and edit following: 

  • Disable accelerated 2D canvas
  • GPU rasterization
  • Hardware-accelerated video decode
  • Zero-copy rasterizer
Highlighted
Hot Shot
Hot Shot

We are not using grid cards, but I have the VMs set to use 128 MB of memory so that wouldn't be the issue.  Plus it is literally only Chrome (at least at this point) that has the issue.  I'll check out the Chrome://flags settings you posted and give that a try.  I have disabled Hardware acceleration in Chrome, and that didn't do anything, but I'll try these out as well.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Can you try logging into your gold image from vSphere console and see if it still occurs.

Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
0 Kudos
Highlighted
Expert
Expert

disabling hardware acceleration in chrome should work. I do this by using a group policy.

You can also try unchecking h.264 in your client to see if that fixes the fuzziness. Maybe you are seeing the effects of blast using h.264.

Highlighted
VMware Employee
VMware Employee

agree 100% with this solution , it should solve this issue

0 Kudos
Highlighted
Hot Shot
Hot Shot

So I've used group policy to disable Hardware Acceleration, and the 3D Graphics APIs, I've tried with PCOIP, Blast with h.264 disabled and Blast with it enabled.  The protocol I use has no effect and the group policy settings seem to help a little bit but there are still a ton of webpages that just look terrible that don't look bad in Chrome on Windows 7.

0 Kudos
Highlighted
Hot Shot
Hot Shot

I also tried using the vSphere console on the gold image and everything works properly there.  It is only through Horizon View that it has issues.

0 Kudos
Highlighted
Hot Shot
Hot Shot

I did some digging as this more and more doesn't seem to be a horizon specific issue.

Check out this old forum link: LinusTechTips. I know you mentioned you disabled DPI but did you disable DPI scaling on the chrome exe AND reboot. Then shutdown and snap.

Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
0 Kudos
Highlighted
Expert
Expert

can you show us a screenshot of what it looks like?

0 Kudos
Highlighted
Hot Shot
Hot Shot

So I figured this out.  It turns out it is a combination of the hardware acceleration and ClearType.  You absolutely need to have cleartype turned on so I used UEM to set the registry key HKCU\Desktop\FontSmoothing to 2 for all users that login and Chrome looks great.  Thanks for all of the help everyone.

0 Kudos
Highlighted
Contributor
Contributor

Can you elaborate on what you did?  I don't have a "Desktop" registry key when I look at my registry through my VDI desktop, was going to try to change it manually and test first.

Then I tried creating a DEM setting to do it like you did, but I'm not sure if it's supposed to be a string vaule or dword or what to set the value of "2".

0 Kudos