SMSgt
Contributor
Contributor

Error message - Unable to automatically reconnect to VC. It is possibly down

Jump to solution

All –

I have a new installation of View Connection Server (VCS). My one and only pool disables provisioning (‘Enable or disable’ link from the pool summary tab) after attempting to connect to the Virtual Center Server (VC). I see “Error during provision 4/15/10 11:12:07 AM MDT: Unable to automatically reconnect to VC. It is possibly down". If I follow the ‘Enable or disable’ link it shows ‘Provisioning is: disabled’. I can enable provisioning and 5 minutes later it will be disabled.

When I go to events I have many errors and warnings, all of them end with “Unable to automatically reconnect to VC. It is possibly down.”

Seems to me I can’t connect to the VC, that's why provisioning is being disabled. The VC is not down. Any ideas as to what I need to do to establish this comm, or at least how to start tshooting it?

Thanks,

E

0 Kudos
1 Solution

Accepted Solutions
mittim12
Immortal
Immortal

Ok, so can you rdp into the den-viewxp01 from your physical workstation? If RDP works than make sure the windows firewall inside the VM is turned off and try again. If that doesn't work I would run the vdm-support script and see if you can find anything in the logs.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

View solution in original post

0 Kudos
24 Replies
mittim12
Immortal
Immortal

Is this your only pool or do you have other pools that seem to work ok? What about trying to setup an individual desktop to see if your connection to vCenter works that way? I would also verify DNS is working correctly and that whatever account you are using for connection to vCenter is setup correctly.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
SMSgt
Contributor
Contributor

Thanks for the quick response.

This is my only pool. Yesterday I created a second pool to see if the result would be any different. I still received the error so I tried uninstalling the VCS and reinstalling, no joy.

What do you mean "Set up an individual desktop?" I'm game if you can point me in the right direction.

I can ping VCS by name from VC and vicey versy. Both servers are 2003 servers and both servers have the firewall turned off. I'm using my domain administrator account to administer both servers but if you can give me something specific to look for user-account-wise I'll check.

E

0 Kudos
rosspcs
Enthusiast
Enthusiast

I would verify the connectivity, can you run the VC client form the View server ? if so verify the VC settings in the view config

mittim12
Immortal
Immortal

If you setup an individual desktop then it will enumerate qualifed desktops currently managed by vCenter so that would say connection is good. I also meant to ask if this were a linked clone pool or a standard pool.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
SMSgt
Contributor
Contributor

Good idea. I hit the IP address of my VC server, downloaded the client, and connectivity is verified. Maybe I should have used DNS to find the VC, but pinging the VC servername returns the IP address so it seems moot anyway. How about I delete my VC from View Manager (it's in by servername) and add it by IP?

0 Kudos
SMSgt
Contributor
Contributor

"Individual Desktop". Oh, you mean one of those...

Ok, I'll give that a try and will report back.

This is Linked Clone. If spent a lot of time in chapter 6 of the View Manager Administration Guide View Manager 4.0.1 to get this set up. View401_admin_guide.pdf

E

0 Kudos
mittim12
Immortal
Immortal

You can setup a non linked clone desktop pool and make sure it provisions ok. If it does we can concentrate on the Composer piece of the environment.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

SMSgt
Contributor
Contributor

Ok, I set up both an individual and a automatic, non-linked clone pool. Neither of them work. The error I get from the view client is "The desktop has failed to open. This desktop currently has no desktop sources available. Please try connecting to this desktop again later, or contact your system administrator"

0 Kudos
SMSgt
Contributor
Contributor

So, error message says no desktop sources available, yet I can see 4 desktops in the Desktop Sources tab.

0 Kudos
mittim12
Immortal
Immortal

The desktop failed to open error message is typically indicative of a communication breakdown between the VM and the connecting PC. It is different than the error creating the linked clones desktops. In order to troubleshoot the connection verify connectivity from the connecting physical PC and the VM by utilizing remote desktop, verify the view agent is running in the virtual machine, double that no firewalls are blocking communication between the physical PC and the VDI machine.

To troubleshoot the linked clone issue you need to focus on the composer portion of the install. Review the admin guide and verify that you setup your composer database correctly, that the service is installed and running on the VC, and that your composer account has the correct permissions. You can find some documentation on composer at page 137 on the following link, http://www.vmware.com/pdf/view401_admin_guide.pdf.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
SMSgt
Contributor
Contributor

Thanks for all your help on this. I'll be able to work on it some more later this afternoon.

0 Kudos
rosspcs
Enthusiast
Enthusiast

As you must have connectivity to a DC is there any reason you cannot use DNS ?

0 Kudos
SMSgt
Contributor
Contributor

If you're talking about my suggestion to remove the virtual center (which is currently added by name) and re-add it by IP address, I was only suggesting that doing so would remove DNS from the equation. Like I said, I can ping the VC from the VCS so I'm thinking that DNS is working and is not the problem.

0 Kudos
mcasekar
Enthusiast
Enthusiast

Hi,

Can you share your errors as screen shots to us to understand the exact problem. I think it will help us to windup the issue.

Regard

Rajasekar

Regards| Rajasekar.N| "If you find this answer useful, please consider awarding points by marking the answer correct or helpful"
0 Kudos
SMSgt
Contributor
Contributor

Here's one error, from Internet Explorer:

And here’s the error from the client:

0 Kudos
mittim12
Immortal
Immortal

Have you verified RDP connectivity from the physical workstation and the VDI machine?

Have you verified that the VMware agent is running on the VDI machine?

is this pool setup for direct mode meaning physical workstations connect straight to the desktop or indirect meaning you are tunneling through the connection broker?

Are you connecting from inside the LAN or outside of the LAN?






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
SMSgt
Contributor
Contributor

RDP connectivity has been verified.

Not sure about the direct/indirect question, probably whatever default is. I'm not able to access it today so I can't check. I apologize for that, I'll be back in front of it this evening. I'll verify the setting then and report back.

Connecting from inside the LAN.

Thanks everyone for helping on this, and I again apologize for not being able tojump right on your suggestions. Got called away this weekend but I'll be back in full swing tomorrow. Thanks again.

0 Kudos
mittim12
Immortal
Immortal

I don't remember what the default it but to check it you can go into the admin page, configuration, servers, and see what the server is set to. If it's direct mode you have nothing to worry about since you verified RDP. If it's not direct you will have to verify RDP from the connection broker. Direct mode is what we run inside our our LAN. Also need to verity the VMware agent status on the VDI machines and make sure they are showing up as ready in the admin console. Let us know how it goes.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
SMSgt
Contributor
Contributor

Ok, I just checked, direct mode was NOT checked. I checked it, still no joy.

I have an XP template, when it's not a template I can RDP to it from my desktop. I re-ran the view agent setup on it, the setup program ran and asked for a reboot. After the reboot I checked, the view client is started. So I then deleted all my pools and started over. I converted the XP desktop to a template and during the creation of the pool I saw and picked the XP template. Pool creation finished with no errors. I entitled myself and can see a virtual machine name of den-viewxp01 (significant because my naming template is den-viewxp0, we know it's creating a machine for me).

Alas, I still get the same error.

E

0 Kudos