Error in creating database.yml file - JMP Server installation

Jump to solution

I'm receiving the following error when trying to install JMP Server 7.6.0-9823717.

JMP installation error.png

I'm following the official docs:

https://techzone.vmware.com/sites/default/files/resource/quick-start_tutorial_for_vmware_horizon_jmp...

Quick-Start Tutorial for VMware Horizon JMP Integrated Workflow - Installation | VMware

Install JMP Server

The OSs and apps seem to be supported. I'm using Server 2016 and SQL Server 2016 Enterprise x64 SP2.  The SQL Servers are a part of a two-node synchronous AAG. I've tried installing to a standalone database that's not protected by the AAG as well an AAG database. Both resulted in the same error above.

Of course, I think it's SQL permissions related, but here are my SQL configs. All looks right to me. I've also tried a new database (named JMP, not shown) with a new local SQL user (named jmp, not shown) and it resulted in the same error above.

JMP-SQL config 1.png

JMP-SQL config 2.png

JMP-SQL config 3.png

JMP-SQL config 4.png

JMP-SQL config 5.pngJMP-SQL config 6.png

JMP-SQL config 7.png

JMP-SQL config 8.png

JMP-SQL config 9.png

Here are the contents of the create_db_config_file.log file mentioned in the error. Pretty useless for me.

C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/site_ruby/2.3.0/rbreadline.rb:1097:in `<module:RbReadline>': HOME environment variable (or HOMEDRIVE and HOMEPATH) must be set and point to a directory (RuntimeError)

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/site_ruby/2.3.0/rbreadline.rb:17:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/site_ruby/2.3.0/readline.rb:10:in `<module:Readline>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/site_ruby/2.3.0/readline.rb:8:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/vendor/thor/lib/thor/line_editor/readline.rb:2:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/vendor/thor/lib/thor/line_editor.rb:2:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/vendor/thor/lib/thor/base.rb:8:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/vendor/thor/lib/thor.rb:2:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/vendored_thor.rb:8:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/friendly_errors.rb:5:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from C:/Program Files (x86)/VMware/JMP/com/XMS/ruby/lib/ruby/gems/2.3.0/gems/bundler-1.16.1/exe/bundle:21:in `<top (required)>'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/bin/bundle:22:in `load'

from C:/PROGRA~2/VMware/JMP/com/XMS/ruby/bin/bundle:22:in `<main>'

----------------------------------------- Please consider marking this answer "correct" or "helpful" if you found it useful (you'll get points too). Mike Brown VMware, Cisco Data Center, and NetApp dude Sr. Systems Engineer michael.b.brown3@gmail.com Twitter: @VirtuallyMikeB Blog: http://VirtuallyMikeBrown.com LinkedIn: http://LinkedIn.com/in/michaelbbrown
1 Solution

Accepted Solutions
DEMdev
VMware Employee
VMware Employee

Hi VirtuallyMikeB,

I'm completely unfamiliar with the JMP installer (I pretty much only know about UEM :-), but that HOME environment variable (or HOMEDRIVE and HOMEPATH) must be set and point to a directory bit in the error message seems worth looking into. Are any of those env vars set? If not, can you try setting them and retrying the install?

View solution in original post

6 Replies
DEMdev
VMware Employee
VMware Employee

Hi VirtuallyMikeB,

I'm completely unfamiliar with the JMP installer (I pretty much only know about UEM :-), but that HOME environment variable (or HOMEDRIVE and HOMEPATH) must be set and point to a directory bit in the error message seems worth looking into. Are any of those env vars set? If not, can you try setting them and retrying the install?

sjesse
Leadership
Leadership

Another thing to check as I remember getting this error, there is a "use ssl" check box for the database, try unchecking that if you haven't. I checked my dev environment that has that running and my service account has way more limited permissions that you have and its working.

0 Kudos

Thanks. We're not using SSL for SQL so I've been unchecking that box during installation.

----------------------------------------- Please consider marking this answer "correct" or "helpful" if you found it useful (you'll get points too). Mike Brown VMware, Cisco Data Center, and NetApp dude Sr. Systems Engineer michael.b.brown3@gmail.com Twitter: @VirtuallyMikeB Blog: http://VirtuallyMikeBrown.com LinkedIn: http://LinkedIn.com/in/michaelbbrown

Holy cow...it worked. There were no HOME, HOMEDRIVE, or HOMEPATH environment variables created. So I just added a HOME environment variable and set it to C:\users\mbrown and the installation succeeded. Huh. Thanks, man!

----------------------------------------- Please consider marking this answer "correct" or "helpful" if you found it useful (you'll get points too). Mike Brown VMware, Cisco Data Center, and NetApp dude Sr. Systems Engineer michael.b.brown3@gmail.com Twitter: @VirtuallyMikeB Blog: http://VirtuallyMikeBrown.com LinkedIn: http://LinkedIn.com/in/michaelbbrown
Lost_Steak
Enthusiast
Enthusiast

An extension is that it needs to be local drive (for my case anyway). I couldn't get it to work when HOMEDRIVE and HOME were network shares.

edittech
Contributor
Contributor

What worked for me was to run the program as the local administrator account.

0 Kudos