Highlighted
Hot Shot
Hot Shot

Disable RTAV at the client instead of agent using GPO

Jump to solution

I dont see this as a client option in the latest GPO bundle VMware-Horizon-View-Extras-Bundle-3.4.0-2769709.zip, ony an agent option.

We want RTAV on in the pool but off for certain clients. How can we accomplsh this? Enabling the policies "Exclude all devices" and disabling the policies "Allow Audio Input Devices, and Allow Audio Output Devices" is not having the desired effect. How else can we accomplish this?

I recommend having this ability in the client GPO's.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

ok...

so to disable audio out from the guest on a windows client (for all users of the client) try setting this:

x64

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware USB\PCoIPAudioForwarding     Disabled     1

x86

HKEY_LOCAL_MACHINE\SOFTWARE \VMware, Inc.\VMware USB\PCoIPAudioForwarding

I believe there is a similar key under HKCU too, but sounds like you want a blanked on/off

I know this sounds like its a USB related key, but its not. its fr the audio out.

cheers

peterB

View solution in original post

0 Kudos
15 Replies
Highlighted
Hot Shot
Hot Shot

I just found this but it is not working as a dword, also tried in HKLM\SOFTWARE\Wow6432Node. Need to reboot?

Real-Time Audio-Video (RTAV) for Horizon View - VMware End-User Computing Blog - VMware Blogs

Setting Client-Side Resolution / Frame Rate

It is possible to configure image frame rates and resolution up to the maximum value specified by the administrator. If the value specified in the client exceeds the value set by the admin, then the value will be capped at the admin-set maximum.

To configure these values, start the Registry Editor (regedit.exe). Navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\RTAV

Registry SettingDefaultComment
IsDisabled0RTAV is enabled by default. If on a per client basis you want to disable, then set this value to 1.
0 Kudos
Highlighted
VMware Employee
VMware Employee

Hey Eric

Do I still score the community points then having written the blog that helps?

Tbh, I need to check if that config value is still available.

Can I ask what is are your client devices?

Cheers

Peterb

0 Kudos
Highlighted
Hot Shot
Hot Shot

All the points are belong to you. This is fully patched Winodws 7 Enterprise 64bit SP1 with Horizon (local only) client 3.4.0 build 2769709 running on a Dell 780 http://i.dell.com/sites/doccontent/shared-content/data-sheets/en/Documents/optiplex_780_tech_spec_sh...

0 Kudos
Highlighted
VMware Employee
VMware Employee

so that regkey still exists on my laptop... i guess that isn't absolute proof its still being honored, ) unf i cant check the code right now.

should be quick to test though. maybe you can post back when you know...

cheers

p

0 Kudos
Highlighted
Hot Shot
Hot Shot

Yeah, its not working. Sound is still coming down to the client from the agent. Here are the current settings. Do I have them right?

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\VMware, Inc.\VMware VDM\Client\USB]

"AllowAudioIn"="false"

"AllowAudioOut"="false"

"ExcludeAllDevices"="true"

[HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\RTAV]

"IsDisabled"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware VDM\RTAV]

"IsDisabled"=dword:00000001

0 Kudos
Highlighted
VMware Employee
VMware Employee

yeah; looks about right. did you fully restart the client first though ? (ensuring it wasnt just minimised to the tray)

alternatively deleting C:\Program Files (x86)\VMware\VMware Horizon View Client\ViewMMDevRedir.dll   would make sure rtav doesnt work. but, unf if you upgrade the client then it would come back...

post back about the client restart. and i can ping some folks tomorrow to check the status of that regkey...

cheers

p

0 Kudos
Highlighted
Hot Shot
Hot Shot

I even rebooted. For now we will rename the dll and wait to hear.

Again, Peter saves the day!

Not so fast. Renamed the dll and sound still comes through. I even renamed C:\Program Files (x86)\VMware\VMware Horizon View Client\x64\ViewMMDevRedir.dll and both rtavvlilib.dll 's

0 Kudos
Highlighted
VMware Employee
VMware Employee

many thanks to Sarah who helped verify this whilst I slept...

isDisabled is still there and works as expected

Looks like some error in your config

1. you should not modify \\policy\usb gpos.

2. even on 64bit OS, RTAV registry key is still @ HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\RTAV

3. IsDisabled is not dword, by default, it is REG_SZ, value is 0.   what you need to do is changing the value to 1, then rtav will be disabled.

Sarah tested and confirmed this works. 

Let us know how you get on.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Even after setting that as a REG_SZ, I am still getting sound. Yes, we do not modify policy in the registry, just included those values to consolidate the view for readers.

A default key value pair did not exist. Here is the current value:

[HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\RTAV]

"IsDisabled"="1"

Maybe someone can replicate our bitness setup? Both client and agent are Win7 64bit.

On the virtual desktop, the agent version is 6.0.2.2331487 with the VMware Virtual Audio (Dev Tap) driver using vmwvaudio.dll 6.01.00.0000 and VMware Tools 9.4.5.1734305

On the client, the view client is VMware-Horizon-View-Client-x86_64-3.4.0-2769709

0 Kudos
Highlighted
VMware Employee
VMware Employee

ah. hang on. "getting sound" - are you talking about audio out - ie hearing audio out of the speakers?

or audio-in - microphone input into the virtual desktop?

0 Kudos
Highlighted
VMware Employee
VMware Employee

(I'm about to travel home, so let me provide more context...)

rtav has absolutely nothing to do with Audio Out (Speakers listening to music etc)

those keys:

"AllowAudioIn"="false"

"AllowAudioOut"="false"

"ExcludeAllDevices"="true"

     these ONLY apply to devices redirected by USB devices.

if you need to disable audio-out , i need to talk to some other folks to remind myself how best to do that.

the isDisabled for the rtav regkey should ONLY stop webcam redirection and microphone redirection. (please confirm if thats not what you are seeing)

pls confirm the use case.

cheers

p

0 Kudos
Highlighted
Hot Shot
Hot Shot

Oh, sorry for not being more specific. This explains why we keep hearing sound on the client. Yes, I am interested in preventing sound going from agent to client. Thinking about it, we will want to prevent the webcam and microphone too and for that we use IsDisabled, got it.

After the DLL and IsDisabled method didnt work, we contemplated using the client vmware mac address environment variable to identify the client in a login script to mute audio on the agent but that just sounds (no pun intended) kludgey.

0 Kudos
Highlighted
VMware Employee
VMware Employee

ok...

so to disable audio out from the guest on a windows client (for all users of the client) try setting this:

x64

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware USB\PCoIPAudioForwarding     Disabled     1

x86

HKEY_LOCAL_MACHINE\SOFTWARE \VMware, Inc.\VMware USB\PCoIPAudioForwarding

I believe there is a similar key under HKCU too, but sounds like you want a blanked on/off

I know this sounds like its a USB related key, but its not. its fr the audio out.

cheers

peterB

View solution in original post

0 Kudos
Highlighted
Hot Shot
Hot Shot

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware USB\PCoIPAudioForwarding     Disabled     1

Worked like a charm!

Thanks Peter and Sarah!

0 Kudos
Highlighted
Contributor
Contributor

Hi peter,

Gooday.I hope your still active on this thread.:)

Got the same issue with having audio comes out on the speaker not on the thin.any suggestion on this?I need to make the adjustment from the end point , im using thin client having win10 86x.

Value NameconnectUSBOnStartup
Value NameconnectUSBOnInsert
0 Kudos