Contributor
Contributor

Desktop resize in Win7

Does anyone else experience the following with View 4 and Windows 7:

  • when maximizing the View Client window, the Windows 7 guest desktop does not generally resize. It sticks with the original display resolution set on the guest OS console. Even when I specify "full screen" during the initial connection, the desktop size seems to remain planted at the "native" resolution.

  • if I resize (not maximize) the client Window, the guest OS does (usually) resize, unless I make it "too big". I have yet to figure out where the "too big" line is precisely.

  • If I mess with resizing often enough, particularly when making the window "too big", I generally get "black screened". Still connected, but can't see anything. Other times, the Viewer begins to repaint the resized window and then abruptly closes.

The behavior leads me to believe I'm dealing some limit on the top-end resolution with a Win7 guest. It seems to be different with a Windows XP guest. The XP desktop seems to reliably resize no matter what size I set the View Client window to be, both during initial connect and while working.

Using View 4 GA, vSphere, and Win 7 32-bit. The desktop where I'm running the View client has a native res of 1680 x 1050 and is running Win7 x64.

0 Kudos
3 Replies
Contributor
Contributor

For what it's worth, figured something out here... I set the "native" resolution of the guest to the maximum I expect to be connecting at (1680x1050), and restarted the VM - making the above mentioned problems disappear. Not sure if I missed something in release notes or documentation otherwise, but this seems to be the fix for me.

0 Kudos
Enthusiast
Enthusiast

This worked for my XP desktop - (making the pool's MAX resolution less than the native desktop's) - no more black screen on XP

However this did not help on my Windows 7 desktops - still get the errors

12/16/2009, 11:58:03> LVL:0 RC: 0 MGMT_IMG :cSW_HOST_IPC::enable_frontend failed. Retry...

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :Calling open display

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :configure_displays: 1 display(s) initially reported!

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :configure_display[0]--* id: 22 mon_id: -1 pos: (0,0) w: 1024 h: 768

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :configure_display[0]--bpp: 32 --pitch: 4096 --map size: 1552 --fb size: 3145728

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :configure_displays: frontend motion is enabled

12/16/2009, 11:58:04> LVL:0 RC: 0 IMG_FRONTEND :flip_frame_buffer: error result - level 1=4001, level 2=0

12/16/2009, 11:58:04> LVL:0 RC: 0 MGMT_IMG :cSW_HOST_IPC::enable_frontend failed. Retry failed 5 time.

12/16/2009, 11:58:04> LVL:2 RC: 0 MGMT_IMG :Resetting codec (end_to_end=0)

12/16/2009, 11:58:04> LVL:0 RC: 0 MGMT_IMG :CODEC: State change from CODEC_CFG_EXCHANGE to CODEC_DISABLED

12/16/2009, 11:58:04> LVL:0 RC:-500 MGMT_IMG :ACTIVE: Fatal error happend. Notifying session manager.

12/16/2009, 11:58:04> LVL:2 RC: 0 MGMT_SSIG :Request to reset session (PRI: 0)

12/16/2009, 11:58:04> LVL:2 RC: 0 MGMT_SSIG :Session closed locally (192.168.45.128, 00-0F-01-01-01-00, PRI: 0)

12/16/2009, 11:58:04> LVL:1 RC:-500 VGMAC :tera_sock_recv() failed - Interrupted system call (10004)!

12/16/2009, 11:58:04> LVL:2 RC: 0 VGMAC :PCoIP UDP RX thread exiting

12/16/2009, 11:58:04> LVL:1 RC: 0 MGMT_DDC :mgmt_ddc_fcc_callback: queuing TERA_MGMT_FCC_EVENT_RESET

12/16/2009, 11:58:04> LVL:2 RC: 0 MGMT_VCHAN :>>> app_reset: Session has been dropped. Forcing all channels to close!

12/16/2009, 11:58:04> LVL:2 RC:-503 MGMT_VCHAN :>>> Failed to close chan 0 because channel is already closed!

12/16/2009, 11:58:04> LVL:1 RC:-500 VGMAC :tera_sock_send() failed - Socket operation on non-socket (10038)!

12/16/2009, 11:58:04> LVL:1 RC:-500 MGMT_PCOIP_DATA :Tx thread error: failed to send packet to VGMAC

12/16/2009, 11:58:04> LVL:1 RC:-500 MGMT_PCOIP_DATA :Tx thread error: failed to encode and queue media packet!

12/16/2009, 11:58:04> LVL:1 RC:-500 MGMT_PCOIP_DATA :Tx thread: error while servicing media channel

12/16/2009, 11:58:04> LVL:2 RC: 0 MGMT_PCOIP_DATA :Reset control block

12/16/2009, 11:58:04> LVL:1 RC:-503 MGMT_PCOIP_DATA :Tx thread error: failed to free small descriptor in control block reset i=0 tx_cblk=148e980

12/16/2009, 11:58:04> LVL:1 RC:-503 MGMT_PCOIP_DATA :Tx thread error: failed to free small descriptor in control block reset i=1 tx_cblk=148e980

12/16/2009, 11:58:09> LVL:1 RC:-500 COMMON :poll_sockets failed to generate 1 callbacks!

12/16/2009, 11:58:09> LVL:1 RC: 0 COMMON :TERA_PCOIP: SESSION_EVENT=TERA_MGMT_SYS_SESS_EVENT_RESET

VCP

VCP5 VSP5 VTSP5 vExpert http://vmadmin.info
0 Kudos
Contributor
Contributor

Interesting that I didn't have any at all issue on XP with a native desktop of 1024x768 and a View pool desktop size of 1680x1050 - but did on Win7, and this fix worked for me.

How much larger did you set the native desktop to be? In my case, I matched the max resolution expected to what I set the native desktop to be on my Win7 (x86) build.

0 Kudos