Hoodsie2018
Enthusiast
Enthusiast

DEM Settings preventing auto-login for floating non-persistent desktops in VMware Horizon?

Without being to see what changed in the past but looking at the current settings, is it possible one of these DEM managed settings for Microsoft Teams is preventing it from auto-logging in to teams after the first time a user logs in? Below are our settings but first I'll share the script that we use to install the machine-wide installer in our floating non-persistent pool:

SCRIPT:
     msiexec /i c:\temp\Teams_windows_x64.msi /l*v c:\temp\teams-install_new.log ALLUSERS=1 ALLUSER=1

Also not sure if this reg key is needed for this setup in Horizon or only Windows Virtual Desktops like in Azure:
     reg add "HKLM\SOFTWARE\Microsoft\Teams" /v IsWVDEnvironment /t REG_DWORD /d 1 /f


Here are the file app settings in DEM for teams. Our goal was to save preferences but not any cached files which take up a ton of space over time:

 

[IncludeFolderTrees]
<AppData>\Local\Microsoft\IdentityCache

[ExcludeFolderTrees]
<AppData>\Teams\Application Cache
<AppData>\Microsoft\Teams\Cache
<AppData>\Microsoft\Teams\blob_storage
<AppData>\Microsoft\Teams\databases
<AppData>\Microsoft\Teams\Indexeddb
<AppData>\Microsoft\Teams\Local Storage
<AppData>\Microsoft\Teams\tmp
<AppData>\Microsoft\Teams\Service Worker\CacheStorage
<AppData>\Microsoft\Teams\Service Worker\ScriptCache
<AppData>\Roaming\Teams\Microsoft\Teams\Cache
<AppData>\Roaming\Teams\Microsoft\Teams\blob_storage
<AppData>\Roaming\Teams\Microsoft\Teams\databases
<AppData>\Roaming\Teams\Microsoft\Teams\Indexeddb
<AppData>\Roaming\Teams\Microsoft\Teams\Local Storage
<AppData>\Roaming\Teams\Microsoft\Teams\tmp
<AppData>\Roaming\Teams\Microsoft\Teams\Service Worker\CacheStorage
<AppData>\Roaming\Teams\Microsoft\Teams\Service Worker\ScriptCache

[IncludeFiles]
<AppData>\Microsoft\Teams\desktop-config.json
<AppData>\Microsoft\Teams\storage.json
<AppData>\Microsoft\Teams\settings.json
<AppData>\Microsoft\Teams\Preferences
<AppData>\Microsoft\Teams\preauth.json
<AppData>\Microsoft\Teams\Cookies

 

 

0 Kudos
7 Replies
BenTrojahn
Enthusiast
Enthusiast

<appdata>  and <appdata>\roaming are the same place.

It seems like most everyone does DEM profiles differently, for a sanity check i would start with this:

[IncludeFolderTrees]
<AppData>\Microsoft\Teams
<LocalAppData>\Microsoft\IdentityCache

then exclude what you dont want.  You seem to imply your setup was working OK before so I'll take it at that.  if not, start with the above.

Right click the TEAMS icon in the system tray and  "Sign Out"  you will then get a login prompt.  If it auto-login again OK you, definitely have an issue in your DEM profile and i would expand your capture a bit.

alternatively to determine what specific file is wrong in your DEM profile, you can disable flex, and remove the files from your exclude list... verify autosign in... rinse/repeat.  

0 Kudos
Hoodsie2018
Enthusiast
Enthusiast

If I sign out it definitely prompts me to sign in again. I tried signing in again, then logging off and then logging into a new vdi session and it still didn’t auto-login to teams once logged into windows.

Hopefully that was decipherable lol

Also, how do I verify what <appdata> and <appdata>\roaming are? I guess I should clean that up? just put in as one? 

0 Kudos
BenTrojahn
Enthusiast
Enthusiast

folder tokens are in the product manual/documentation.   <appdata> = %appdata%  <localappdata> = %localappdata%

Open your DEM zip archive and seeing what's in it.  then the paths might make more sense.

0 Kudos
Hoodsie2018
Enthusiast
Enthusiast

thanks yeah figured out my appdata was pointinging to appdata\roaming. so removed that redundant one. 

do any of those excluded ones cause it not to auto-login? 

0 Kudos
RoderikdeBlock
Enthusiast
Enthusiast

This is our config which works perfect. Profile is only 150kb per user.

[IncludeFolderTrees]
<LocalAppData>\Microsoft\Credentials
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\
<LocalAppData>\Microsoft\IdentityCache

[IncludeFiles]
<AppData>\Microsoft\Teams\desktop-config.json
<AppData>\Microsoft\Teams\preauth.json
<AppData>\Microsoft\Teams\Preferences
<AppData>\Microsoft\Teams\settings.json
<AppData>\Microsoft\Teams\storage.json

[IncludeRegistryTrees]
HKCU\Software\Microsoft\Office\Teams\
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.aad.brokerplugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\PolicyCache\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Mappings\S-1-15-2-1910091885-1573563583-1104941280-2418270861-3411158377-2822700936-2990310272
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.AAD.BrokerPlugin_1000.18362.449.0_neutral_neutral_cw5n1h2txyewy

[ExcludeFolderTrees]
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\INetCache
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\TempState
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\Temp

Roderik de Block


Blog: https://roderikdeblock.com
Tags (1)
0 Kudos
Hoodsie2018
Enthusiast
Enthusiast

Thanks. Going to see if I can give that a try. Does it auto-logon using the windows user's credentials when they log in or do they have to type in their password? The 4 main goals we have are:

  • auto-login in future logins if they start it when logging in for the first time
  • keep roaming profile/user folder very small
  • retain prefernces users' set inside teams
  • be able to do remove video/audio over VDI using blast
0 Kudos
MeyMath
Contributor
Contributor

We modified this config, because we get a login promt every time after relogin:

[IncludeFolderTrees]
<LocalAppData>\Microsoft\Credentials
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\
<LocalAppData>\Microsoft\IdentityCache

[IncludeFiles]
<AppData>\Microsoft\Teams\desktop-config.json
<AppData>\Microsoft\Teams\preauth.json
<AppData>\Microsoft\Teams\Preferences
<AppData>\Microsoft\Teams\settings.json
<AppData>\Microsoft\Teams\storage.json

[IncludeRegistryTrees]
HKCU\Software\Microsoft\Office\Teams\
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.aad.brokerplugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\PolicyCache\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Mappings\S-1-15-2-1910091885-1573563583-1104941280-2418270861-3411158377-2822700936-2990310272
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.AAD.BrokerPlugin_1000.18362.449.0_neutral_neutral_cw5n1h2txyewy

[ExcludeFolderTrees]
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\TempState

 

Additional add into Shared Settings under [IncludeFolderTrees]:
<LocalAppData>\Microsoft\Office\16.0\Licensing

KR
Mathias

0 Kudos