VMware Horizon Community
CTRIM
Enthusiast
Enthusiast

Connection server console message shows "DETECTED UNRECOGNIZED REQUESTS"

We recently updated to Horizon 8. Since then, we are seeing multiple console errors...

Connection server console message shows "DETECTED UNRECOGNIZED REQUESTS"

UAG shows "BROKER DETECTED UNRECOGNIZED SESSIONS"

Has anyone seen these and or come up with a resolution? I cannot find any mention on the net or in kbs.

Edit 07-10-23 We are using F5 load balancer.

52 Replies
kendalgoodrich
Contributor
Contributor

Sorry it's taken so long to update this post, but I was finally able to install the 2306 update and the patch they sent me. Come to find out that alone did not fix the issue. There was one more step, a modification to the ADAM database. Since the upgrade/patch/ADAM mod..... I don't seem to be getting the warnings for the connection servers..... although I am still receiving them for the UAGs. To my understanding I need to update them to 2306 as well then reach out for a modification that needs to happen on them similar to the ADAM mod. I'm kind of wondering if the ADAM modification will work WITHOUT the patch..... I will update when I am able to proceed with the UAG upgrades.

kendalgoodrich_0-1702051075372.png

 

VMHero4Ever
Enthusiast
Enthusiast

Hi,

I find a simple way how to disable this message for the UAGs.

    • Download existing UAG config JSON from admin UI
    • Search for key 'unrecognizedSessionsMonitoringEnabled' in JSON
    • The current value in JSON will be true. Change this to false
    • Save JSON
    • Import the modified JSON to UAG

This work for me with UAG 23.03.


Arnaud_Lebret
Contributor
Contributor

Hi,

thanks for sharing this kendalgoodrich, i added the modification in the ADAM database yesterday afternoon, no more "DETECTED UNRECOGNIZED REQUESTS" messages for the connections servers.
Horizon 2309 install, without any patch, it works !

I will try the solution for UAG asap(thanks VMHero4Ever), hope to see Horizon console System Health with 0 issues, almost a year with this error messages, after upgrading to 2212.


Reply
0 Kudos
Patrick4
Contributor
Contributor

Hi ,

do you need to do the modification on all connection servers ? or the database will replicate itself ? 

 

Thank you

Reply
0 Kudos
MP-CAE
Enthusiast
Enthusiast

Hey @Arnaud_Lebret,

 

Do you happen to have the exact modification you made in the ADAM database?  I'd like to try it out and see for myself how it works in our infra with no UAGS - just Connection Servers.

Any details, sources or reference links would be appreciated.

Thanks!

Reply
0 Kudos
Arnaud_Lebret
Contributor
Contributor

Hi @MP-CAE,

you just have to add enable-xml-api-warning=0 in the attribute "pae-NameValuePair". You can edit this attribute in OU=Properties > OU=Global > CN=Common or CN=Common Properties

 

Arnaud_Lebret_0-1704812785102.png

Then search for pae-NameValuePair and click modify to add the value :

Arnaud_Lebret_1-1704813031915.png

That's all, add only on one connection server @Patrick4, for your question), wait a little time for replication, and no more error messages.

 

MP-CAE
Enthusiast
Enthusiast

Merci @Arnaud_Lebret - much appreciated!

I'll give that a try and see how things go.

UPDATE:
I made the "enable-xml-api-warning=0" update to my Connection Servers (running 8.8.0 - 21073894 (2212)) and let it sit for a few days and nada - I still have the same issue unfortunately.

MPCAE_0-1705424618897.png

Reply
0 Kudos
chriskoch99
Enthusiast
Enthusiast

@TimUFHJ what was the result?  Did 2212.2 resolve the issue?

Reply
0 Kudos
Arnaud_Lebret
Contributor
Contributor

Hi @MP-CAE,

I think you need to update your Connection Servers at least to version 2306 for this to work.

MP-CAE
Enthusiast
Enthusiast

Hey @Arnaud_Lebret - thanks for the tip there too!  Ok I'll add the upgrade to the mix soon and see how that fares.  May take me a bit since it's a prod infra but I'll let folks know how that works over here.

As always much appreciated!

Tags (1)
Reply
0 Kudos
SchwarzC
Enthusiast
Enthusiast

Did the upgrade to 2212.2 - still the same messages

Reply
0 Kudos
dragans2
Contributor
Contributor

I have updated to version 2312, and still the same messages.

Reply
0 Kudos
dbaker999
Contributor
Contributor

We have the same problem for a customer environment:

Patched customer from 2206 to 2303, UAGs to 2303.1.

F5 load balancers in front of internal and external UAGs.

To give some context, we spent 3 months working with GSS to try and disable the feature. The customer didn't want to see warnings (regardless of if they were false positives) when they were testing connectivity and failing over their UAG's manually. Under normal working conditions I would expect the Source-IP persistency on the load balancer to prevent a user from reconnecting to an existing session via a UAG that had a stale session cookie (obviously this implies that at some point they had logged on via a diffferent UAG, but in normal working scenarios a user should connect via one UAG, then be re-directed via that UAG if they disconnect/reconnect - right?).  After we finished patching the estate, they manually disable each UAG in the load balancer to test connectivity and that both UAGs work as expected, which is understandable. In doing so, they reconnect via existing session cookies which, of course, generates the warnings. This alarms them, and they requested the feature be removed.

GSS issued a hot fix to us + LDAP enable-xml-api-warnings=0 + "UnrecognizedSessionsMonitor" value = false on UAG config. No joy. The hotfix didn't install, broke global replication and caused more problems than expected.

As it stands, we are looking to either patch them to a later version of Horizon where this feature is not present, or change their internal testing processes to try and reduce the change of these warnings appearing. I'd be keen to know if, based on my comments above, source IP persistency should prevent these warnings from occuring (assuming the LB is configured correctly...). 

What version of Horizon is this feature actually disabled or doesn't generate false positives? 

Reply
0 Kudos