VMware Horizon Community
CTRIM
Enthusiast
Enthusiast

Connection server console message shows "DETECTED UNRECOGNIZED REQUESTS"

We recently updated to Horizon 8. Since then, we are seeing multiple console errors...

Connection server console message shows "DETECTED UNRECOGNIZED REQUESTS"

UAG shows "BROKER DETECTED UNRECOGNIZED SESSIONS"

Has anyone seen these and or come up with a resolution? I cannot find any mention on the net or in kbs.

Edit 07-10-23 We are using F5 load balancer.

51 Replies
ATDEHART
Contributor
Contributor

Worth noting we just upgraded to 2306 and experience the same issues. We have load balancers in front of our external UAG's but not the internal ones and I see the errors on both sides.

Just thought I'd chime in as another 2306 user since https://kb.vmware.com/s/article/90398 says It was fixed still in 2303 up which clearly isn't the case.

Reply
0 Kudos
robinsonjl3
Enthusiast
Enthusiast

Just to chime in and add my two cents.  I have a small environment with no load balancers and running 2303 with only internal customers and I get the same message.

GTO455
Enthusiast
Enthusiast

Adding my 2 cents as well. We recently upgraded to 2306 and seeing the error as well, but only concerning internal Connection Servers, my UAG's are showing all green.

I sent my "LB Guy" the relevant VMware KB's, but he can't find anything wrong.

Looking at the debug logs, we see the following lines, but searches haven't turned up anything of value (except this thread).

Nothing immediately immediately before or following this entry provides any relevant information either.

<MessageFrameWorkDispatch> [MessageFrameWork] KeyVaultWorker::MessageHandler(): KeyVault service got operation=decipherWithDerivedKey, ok=1, msecs=16
<ajp-nio-127.0.0.1-8009-exec-1> [ConnectionServerHandler] Incrementing the warning count : Reason : unrecognized request detected

vm_rpl
Contributor
Contributor

We upgraded our Horizon to last ESB version 2212.1 and got same alerts. We use Citrix ADC for UAGs and CS. LB have correct settings which we compared with VMware recomendation. Would to disable this messages on Horizon's Dashboard.

Reply
0 Kudos
kendalgoodrich
Contributor
Contributor

Hello all,

I've been working an SR with VMWare on this issue and their response/solutions is:

Upgrade to version 8.10(2306)

Apply a Hot Patch they made available to me via FTP download: VMware-Horizon-Connection-Server-x86_64-8.10.0-22364614.exe

I have not upgraded and tested yet, but will update this post once I confirm this works or not.

 

Tags (1)
MP-CAE
Enthusiast
Enthusiast

Hey @kendalgoodrich,

That sounds like promising news - please do keep us posted on the progress and if it works or not! 👍🏽

Reply
0 Kudos
ATDEHART
Contributor
Contributor

Yes very interested in how that goes.  They had offered a hot patch but we decided to forgo messing with our production system right now since this is more cosmetic than anything.

I'd be curious with 2306.1 out now if that addresses it or if we'll need yet another patch. (2306.2?? 😀  )

Incidentally, we've removed our load balancers and are just using an HA UAG config and the problem persists so it isn't load balancers causing our problem.

 

Reply
0 Kudos
misikan
Contributor
Contributor

We have exact same issues. we just upgraded to 2306 and experience the same issues. We have load balancers in front of our external UAG's to 2 connection server and also 2 connection server internal side with load balancers. 

we see the errors on external sides both UAG's and Connection Servers

Reply
0 Kudos
AIPlayer
Contributor
Contributor

We applied the hot patch that was provided to us and added a new entry in the ADAM database to disable the alerts.

This has resolved the issue with the "Unrecognized Requests" warnings for our CS but unfortunately, we are awaiting a resolution for the UAG alerts.

ATDEHART
Contributor
Contributor

That's unfortunate it didn't deal with both but glad you were able to test it and have some limited success.

MP-CAE
Enthusiast
Enthusiast

That's great news indeed - even if it just partially resolves your issues!

Can anyone else also confirm that the patch works for their environments?

NelsonCandela
Enthusiast
Enthusiast

Personally I stick to the plan of ignoring it. The environment works, therefore i feel like there's nothing to be done on my end.

 

For the record:

I have set up the environment (2 UAG, 2 CS) in 2306 in the first place, so nothing that is 'fixed' by updating to that version. And since those message appear and disappear all by themselves ... ¯\_(ツ)_/¯

BR
NC

Reply
0 Kudos
tforte007
Contributor
Contributor

NetScaler, yet same errors occur

Reply
0 Kudos
bjohn
Enthusiast
Enthusiast

2309 released. Nothing in the release notes about this stupid issue getting fixed.

Reply
0 Kudos
m1k3yr
Contributor
Contributor

Just upgraded from 7.13 to 2212.1 and seeing the same message.

F5 in front of connection servers.

Environment seems to be working fine.

We have 3 pods.  First Pod is for testing and digital signage and I don't have those messages.  Second Pod is for production use and is seeing the messages.  I have not updated the third Pod yet as it is the other production pod. 

 

Reply
0 Kudos
TimUFHJ
Contributor
Contributor

I adjusted the setting under Servers > Global Settings > General Settings > Discard SSO Credentials, and set it to "After"  "1 minute".
So far I have not encountered this alert anymore.

I have tried disconnecting and reconnecting as quickly as possible.

I have tried logging off an Instant Clone, and relaunching to get a new session.

I am on Horizon 2212.1 (8.8.1 build - 22192183) and UAG 22.12.0.0-21063638

Fingers crossed this will stop these useless events.

MP-CAE
Enthusiast
Enthusiast

Nice ... sounds promising, keep us posted please as to how things go. 🤞🏻

Reply
0 Kudos
TimUFHJ
Contributor
Contributor

My change stopped the alerts for a bit, but now they are back.  So the adjustment i mentioned above does not resolve it.  Back to the drawing board.

Reply
0 Kudos
vm_rpl
Contributor
Contributor

I noticed that 2212.2 version contains resolved issues:

- HZN-314: In Admin UI, the Unrecognized XML API Request warning\Alert count was drastically incremented even for a stale session request.

- HZN-587: Horizon Console dashboard unexpectedly displays an alert "unrecognized requests detected".

https://docs.vmware.com/en/VMware-Horizon/8-2212.2/rn/vmware-horizon-8-22122-release-notes/index.htm...
It seems that next version after 2309 will be include same changes
Now I have't opportunity to upgrage my Horizon. When I'll upgrade CS to 2212.2 I'll write about results. May be anyone upgrages before)

Reply
0 Kudos
TimUFHJ
Contributor
Contributor

I just upgraded my Test environment to 2212.2 yesterday.  Will be working in it all day today, trying to "work like a user" and see if these XML API warning come back.

 

I still have the configuration within the Connection servers, Global Settings, Other Clients > Discard SSO credentials After 1 minute(s).

Not sure this will play into anything, as changing it did not stop the warnings before.

I'm still on UAG version 21.11.1

I'll reply in a few days over how my environment is working and if these warnings have come back.

Reply
0 Kudos