robsisk1972
Enthusiast
Enthusiast

Connecting to a Physical Desktop via the Horizon View Client without the Desktop needing to be UNLOCKED!

Jump to solution

So this worked perfectly in horizon 6 and win 7.  Apparently something has changed in Horizon 7 or Win10 1803.

Really easy to do and here are the basic steps:

  • Create a manual pool, add the physical desktops, entitle, etc.
  • Toss the view agent on the physical desktop
  • Access the physical desktop through the Horizon Client.

Before in Horizon 6 and Win7...Maybe even Win10, users could lock their physical desktop, drive home and reconnect to it via the Horizon client. It would merely unlock the workstation and they could pickup where they left off.

Now...With Horizon 7 and the new agent and clients, users can not do this.  If they lock their desktop, drive home and attempt to connect to it via the View Client, they are greeted with the below messages and can can not get to their machine..  Does anyone now how I can get around this besides having users logoff before the leave the office if they intend to work from home?  Starting here before raising an SR so thanks for looking.

Thanks

rdp.PNG

0 Kudos
1 Solution

Accepted Solutions
robsisk1972
Enthusiast
Enthusiast

OK...I stand corrected.   Apparently, View 7.7 allows the Blast protocol to be used with Physical Desktops.   RDP is no longer require which is great!   I gave it a test really quick and it didn't work but after about 5 minutes, I discovered that the Mcafee Firewall installed on the physical machine was blocking it.    Going to create a quick Mcafee exclusion and I should be good.   Using Blast for physical desktops is a nice feature Vmware.   Kudos for this feature!!!!

View solution in original post

0 Kudos
6 Replies
Avenger429
Contributor
Contributor

Is the physical computer they are locking at work different than the physical computer they are logging into when they get home? If so, then it sounds like the Protocol was changed from 1 machine to the next (e.g. VMware Blast configured at work, PCoIP configured at home.)

0 Kudos
robsisk1972
Enthusiast
Enthusiast

No...It's the same computer.  Also....The protocol in use here is RDP since it's a physical Desktop.    Has nothing to do with Blast or PCoiP.

0 Kudos
robsisk1972
Enthusiast
Enthusiast

OK...I stand corrected.   Apparently, View 7.7 allows the Blast protocol to be used with Physical Desktops.   RDP is no longer require which is great!   I gave it a test really quick and it didn't work but after about 5 minutes, I discovered that the Mcafee Firewall installed on the physical machine was blocking it.    Going to create a quick Mcafee exclusion and I should be good.   Using Blast for physical desktops is a nice feature Vmware.   Kudos for this feature!!!!

0 Kudos
Iannone
Contributor
Contributor

I know this is old but...

Did you ever get this resolved? I have the same issue with Horizon 7.6. If I connect to a virtual desktop, then simply RDP to my physical desktop, I can then disconnect from the virtual and use Horizon to connect directly to the physical without the error.

This happens every single time. As soon as I log onto the actual physical pc, I need to RDP to it first before I can use Horizon.

0 Kudos
gangelozzi
Contributor
Contributor

I had the same issue.  See below this was the fix I used:

In order to fix  the issue with Horizon Agent 7.9 and physical computer access from home Via RDP we need to change the following registry key for all Phyiscal PC:

  • Path : HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\VMware-RDS
    Key : fEnableWinStation

Type : dword
Value: 0

The current default value is 1 and need to be changed to 0.

Let me know if this works for you guys

Thanks

Gino

0 Kudos
robsisk1972
Enthusiast
Enthusiast

@gangelozzi

Gino for the WIN.   The Reg change worked perfectly.     Have to say....I am really not a fan of Blast.   Maybe it's just me and my lack of tweaking it but out of the box, I have may complaints from users.

0 Kudos