foodandbikes
Enthusiast
Enthusiast

Cannot disable printer redirect in RDP

I want to disable printer redirect since it's causing problems and confusion with our users.

I have tried doing the GPO thing with the ADM files and can see the option of RedirectPrinters is false in the user's registry. I have also manually added this to the user registry in another location, but to no avail.

No matter what, when I connect the printers are redirected, and the default printer changes. It's a huge pain right now. It's as if setting it to false means true.

Does anyone have any experience with these settings and getting them to work?

I've even go as far as creating a GPO that applies to the view desktop telling it not to allow printer redirect, and it still does it. Those settings are done via a windows setting and not imported from a VMware ADM file.

Frankly these options should be available in the client GUI like they are in Windows RDP client.

I have no plans on using PCoIP until it can be done without a VPN or direct connect.

0 Kudos
2 Replies
foodandbikes
Enthusiast
Enthusiast

After an hour with tech support it turns out this is a bug.

The only way to get rid of printer redirects is to do the following in this order:

Run this command to delete any printers currently redirected. This has to be done befoire disabling the printers, otherwise the redirected printers will remain even after rebooting.

C:\Program Files\VMware\VMware Tools>TPAutoConnect.exe -d all

Then disable the TPAutoConnSvc and TPVCGateway services. The second service might not need to be disabled.

Due to the order things need to get done, this would be best done through a script.

0 Kudos
idle-jam
Immortal
Immortal

Thanks! for sharing. I learnt something new today .. Smiley Happy

0 Kudos