jbsengineer
Enthusiast
Enthusiast

Cannot delete Replica Folder

Jump to solution

I'm finishing up a evaluation of VMware View 3 and I've deleted all pools and VM's via the View Manager. However the only piece left behind viewable through VC is a folder which help the replica's call "VMwareViewComposerReplicaFolder". I'd like to get this cleared up but am unable to delete it as I get a general system error. Any ideas? Thanks.

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Goto C:\Program Files\VMware Inc\View Composer\

You will find a tool calles SVIConfig.exe

With this tool you can release the folder.

SviConfig

–operation=UnprotectEntity –VcUrl=https://<vchostname>/sdk

-Username=<VC account name> -Password=<VC account password>

-InventoryPath=”/<Datacenter name>/vm/VMWareSviReplicaFolder"

View solution in original post

0 Kudos
8 Replies
admin
Immortal
Immortal

Goto C:\Program Files\VMware Inc\View Composer\

You will find a tool calles SVIConfig.exe

With this tool you can release the folder.

SviConfig

–operation=UnprotectEntity –VcUrl=https://<vchostname>/sdk

-Username=<VC account name> -Password=<VC account password>

-InventoryPath=”/<Datacenter name>/vm/VMWareSviReplicaFolder"

View solution in original post

0 Kudos
jbsengineer
Enthusiast
Enthusiast

Thanks. I'm all set.

0 Kudos
wongh
Contributor
Contributor

Can someone provide me an example of the format of the replica-folder?

I am using

InventoryPath="MyDC/vm/replica-d719637a-07b6-4ffd-8871-"

I got the folder name from the ESX server.

Any feedback is appreciated

0 Kudos
dflint
Enthusiast
Enthusiast

When I run this command it logs in to the VC successfully but comes back with the message "entity not found?

I am trying to delete the folder named VMwareViewComposerReplicaFolder in dCenter1

Any help would be greatly appreciated!

0 Kudos
dflint
Enthusiast
Enthusiast

Issued resolved. My syntax was incorrect

0 Kudos
bonediggy
Contributor
Contributor

What was your syntax?

Under the Virtual Machines and Template Inventory view, I am trying to delete the VMwareViewComposerReplicaFolder under my data center called OIG. Here is my syntax:

C:\Program Files\VMware\VMware View Composer>SviConfig -operation=UnprotectEntity -VcUrl=https://s23

9a60/sdk -Username=root -Password=mypassword -InventoryPath="/OIG/VMwareViewComposerReplicaFolder"

Establishing connection to the VC server.

VC server connection established successfully.

Looking for the entity on the VC server.

SviConfig finished with an error. Exit code: 11

Entity not found.

C:\Program Files\VMware\VMware View Composer>

Any suggestions?

0 Kudos
bonediggy
Contributor
Contributor

Got it. Here is my syntax. In my view my datacenter is OIG and underneat that I have the VMwareViewComposerReplicaFolder. And then under that is my replica vm's. Not sure why I needed add the vm folder path but it worked.

C:\Program Files\VMware\VMware View Composer>SviConfig -operation=UnprotectEntity -VcUrl=https://s23

9a60/sdk -Username=root -Password=mypassword -InventoryPath="/OIG/vm/VMwareViewComposerReplicaFolder/r

eplica-02a7c1ef-5ad0-4282-81ef-e5371aab27f1"

Establishing connection to the VC server.

VC server connection established successfully.

Looking for the entity on the VC server.

VirtualMachine found.

SviConfig finished successfully.

VirtualMachine with MoId vm-6746 sucessfully unprotected.

C:\Program Files\VMware\VMware View Composer>

0 Kudos
Eldron01
Contributor
Contributor

I am trying to remove some orphans, and having problems with this command. My VC server s ihscvdivc01 and my datacenter is ihscvdi.

SviConfig -operation=UnprotectEntity -VcUrl=https://ihscvdivc01/sdk -Username=%myADusername% -Password=%myADpassword -InventoryPath=/ihscvdi/vm/VMwareViewComposerReplicaFolder/source-lc-58c2dff1-9f1e-4ffe-99f0-080c99faf503 -Recursive=True

I get exit code 11

I see that other are using root for this command. How are you using root to log in to the windows VC server? My VC connection fails when I try that.

Any help is apreciated.

0 Kudos