qetutewq
Contributor
Contributor

Broker Session TimeOut after 10 hours. Registry changing isn't work.

Hello!

Active session closes after 10 hours with table"Broker Session TimeOut"

I changed setting in registry and policy. But it is not work.

HKLM\Software\VMware, Inc.\VMware VDM\Agent\Configuration\XMLAPI key SessionTimeout

As well as "userIdleTimeout" key and other.

In console "Forcibly disconnect users: Never"

Horizon 7, agents 7.1

Please tell me where to look for the problem?

0 Kudos
3 Replies
RoderikdeBlock
Enthusiast
Enthusiast

There is also a global setting in the VMware Horizon Admin Console that has to be changend:

3daa02c2fedd5ea49df6996f6f94cf33.png

Roderik de Block Blog: https://roderikdeblock.com
0 Kudos
qetutewq
Contributor
Contributor

Thanks, but the "Forcibly disconnect users" value is set to "Never".

By the way the session will be disconnected even if I just go to the VMware Horizon Client and leave it open and will not go to the desktops.

0 Kudos
knkty
Contributor
Contributor

Hi,

We had the same kind of issue. System was disconnecting users then in 5-10 seconds was logging of the users.

It started suddenly without doing any change. Still don't know the cause but we found a way to fix it. If i remember correct , i found the solution here on the community.

go to your connection server

run mmc and add adsi edit

enter the connection setting as in the screenshot

hit ok

then browse to

DC=vdi,DC=vmware,DC=int

OU=Properties

OU=Global

double click to CN=Common

and set the filter to "show only attributes that have values" find "pae-SessionTimeout" and change the value. Mine is set to 604800. After change restart the services on both connection servers.

pastedImage_0.png

pastedImage_1.png

0 Kudos