nebben
Enthusiast
Enthusiast

Brain dead. Can't get Horizon View Agent to prompt to register with CM.

Jump to solution

I've got a windows 2008R2 box that I want one user to be able to connect to. I install the 6.1.1 agent on this 2008R2 box and select Desktop Mode. I am prompted for which features to install, it installs, then it asks to reboot- but I am never prompted to register with a connection manager.

So far, I haven't found anything in VMware docs that suggest this should be working differently than on desktops. I have read that when trying to install this on a server OS, the RDS role must not be installed or else it will require Datacenter...etc. - I am only trying to get this to allow one single user to have occasional access to this system. ??

0 Kudos
1 Solution

Accepted Solutions
SanjaySP1
VMware Employee
VMware Employee

Hi,

Can you Start the Installer using command prompt (Run as Administrator) to install it in VC Un-managed mode."VMware-viewagent-x86_64-6.1.1-XXXXXXX.exe /v VDM_VC_MANAGED_AGENT=0"

View solution in original post

0 Kudos
5 Replies
SanjaySP1
VMware Employee
VMware Employee

Hi,

Can you Start the Installer using command prompt (Run as Administrator) to install it in VC Un-managed mode."VMware-viewagent-x86_64-6.1.1-XXXXXXX.exe /v VDM_VC_MANAGED_AGENT=0"

View solution in original post

0 Kudos
nebben
Enthusiast
Enthusiast

YEA! Thanks Sanjay!

0 Kudos
mpryor
Commander
Commander

Was this a physical machine? If so it really should have defaulted to that umanaged setting, it may be an installer bug. If it was an ESX VM, it's expected behaviour to be in managed mode by default and not prompt.

0 Kudos
SanjaySP1
VMware Employee
VMware Employee

Thanks for the update nebben, could you please mark this thread as answered.

0 Kudos
nebben
Enthusiast
Enthusiast

ESX VM. From the docs, it would seem that installing the agent would be limited to desktop mode only. This didn't really work as expected except when using @Sanjay's suggestion.

0 Kudos