jrr001
Enthusiast
Enthusiast

Anyone notice connection server admin function slow on 4.6

Jump to solution

I had about 50 desktops in my lab and went through the view 4.5 to 4.6 upgrade. The connection server gave a warning at end of install about configuration not being large enought to it had been tuned to lower values (I had 2 proces and 5 gb of RAM assigned). Performance in the view admin is horible...long waits for items to open and close.

I put in a call to support and they didn't have a way to adjust the parms if you add more RAM after the fact....which is not good.

Anyone finds any tips on resolving this please reply.

0 Kudos
1 Solution

Accepted Solutions
casperinmd
Enthusiast
Enthusiast

Per upgrade guide:

Memory
Windows Server 2008 64‑bit
4GB RAM or higher At least 10GB RAM for deployments of 50 or more
View desktops

5gb could be the issue, the steps per support when I called with low memory issues with having 2 brokers was this:

Remove connection server from server 1, add ram, reinstall connection server. Once it synced up, repeat for server 2.

hth

edit: if you only have 1 connection server, just install a second to get through the change then remove the second/temp server.

View solution in original post

0 Kudos
6 Replies
Linjo
Leadership
Leadership

If you have a look in the documentation there is recommendation of memory for the connection brokers and how to change it if the memory increased post install. Not exactly sure which of the guides but its in there.

// Linjo

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
mpryor
Commander
Commander

I'll also add that recommended memory requirements haven't changed between 4.5 and 4.6, you would have seen the same warning on installing 4.5. Heap sizes for the existing processes haven't changed in 4.6, but on 2008 R2 the PCoIP secure gateway service will also be installed  - when this isn't actively in use though, its memory requirements are very small. For a 50 VM setup the default low-memory installed heap sizes should be fine, are you sure nothing else has changed that would affect the performance of your connection server?

As Linjo said, there are steps in the guide for changing JVM parameters. For reference, HKLM\SOFTWARE\VMware, Inc.\VMware VDM\plugins\wsnm\TomcatService\Params is where you'll find it.

jrr001
Enthusiast
Enthusiast

I am running the connection sever on 2008 R2 (64bit) so I don't think the reg hacks are valid except for server 2003 OS.

When I did the upgrade I did 2 procs and 5 GB of RAM on the connection server. It gave a warning at end of upgrade" Due to limited memory available on this system, the View components have been configured to use reduced resources."  Apparently there is not a way to fix this once these "configured to use reduced resources" has been applied for server 2008 R2 64 bit??????

This is a LAB POC, I had 1 pool of 50 desktops, 20 running and 2 single user VDI machines assigned.

I reduced the pool down to 20 with 10 running.

To edit this pool it takes 32 seconds for the edit pool window to populate.

I am using the built in SQL express on C drive for this which is probably related to the problem.

Think I am going to rebuild and poing to a real SQL server on separate machine and see if it improves.

0 Kudos
casperinmd
Enthusiast
Enthusiast

Per upgrade guide:

Memory
Windows Server 2008 64‑bit
4GB RAM or higher At least 10GB RAM for deployments of 50 or more
View desktops

5gb could be the issue, the steps per support when I called with low memory issues with having 2 brokers was this:

Remove connection server from server 1, add ram, reinstall connection server. Once it synced up, repeat for server 2.

hth

edit: if you only have 1 connection server, just install a second to get through the change then remove the second/temp server.

View solution in original post

0 Kudos
mpryor
Commander
Commander

casperinmd's suggestion is a good one if you don't want to muck about with settings manually - go with that if you're able.

I am running the connection sever on 2008 R2 (64bit) so I don't think the reg hacks are valid except for server 2003 OS.

Still valid, it's pretty much an identical install to 2003 64-bit except that ADAM is built-in to Windows on 2008+, and the PCoIP secure gateway is only available on 2008 R2.

When I did the upgrade I did 2 procs and 5 GB of RAM on the connection server. It gave a warning at end of upgrade" Due to limited memory available on this system, the View components have been configured to use reduced resources."  Apparently there is not a way to fix this once these "configured to use reduced resources" has been applied for server 2008 R2 64 bit??????

That setting is the heap size alluded to in the previous replies, nothing more complicated than that. This same message is present in the 4.5 install as well with the same machine resources.

To edit this pool it takes 32 seconds for the edit pool window to populate.

That's an extremely long time, I still think something else is to blame.

0 Kudos
Renekok
Contributor
Contributor

Hi,

We have the same problem with the broker 4.5, VMware states in its installation guide page 64 the following:

Sizing the Java Virtual Machine

The View Connection Server installer sizes the Java Virtual Machine (JVM) heap memory on View Connection

Server computers to support a large number of concurrent View desktop sessions. However, when View

Connection Server runs on a 32-bit Windows Server computer, the View Secure Gateway Server component

is configured with a limited JVM heap size. To size your deployment adequately, you can increase the JVM

heap size on 32-bit computers.

On a 64-bit Windows Server computer with at least 10GB of memory, the installer configures a JVM heap size

of 2GB for the View Secure Gateway Server component. This configuration supports approximately 2,000

concurrent tunnel sessions, the maximum number that View Connection Server can support. There is no benefit

in increasing the JVM heap size on a 64-bit computer with 10GB of memory.

N

On a 64-bit View Connection Server computer, 10GB of memory is recommended for deployments of

50 or more View desktops. Configure less than 10GB of memory for small, proof-of-concept deployments only.

If a 64-bit computer has less than 10GB of memory, the installer configures a JVM heap size of 512MB for the

View Secure Gateway Server component. If the computer has the required minimum of 4GB of memory, this

configuration supports approximately 500 concurrent tunnel sessions. This configuration is more than

adequate to support small, proof-of-concept deployments.

If you increase a 64-bit computer's memory to 10GB to support a larger deployment, View Connection Server

does not increase the JVM heap size. To adust the JVM heap size to the recommended value, reinstall View

Connection Server.

On a 32-bit Windows Server computer, the default JVM heap size is 512MB for the View Secure Gateway Server

component. This JVM heap size can support approximately 750 concurrent tunnel sessions. To support more

than 750 sessions, the computer must have at least 3GB of memory and the JVM heap size should be increased

to 1GB. A JVM heap size of 1GB supports 1,500 concurrent tunnel

OTE

So meaning that a system with less than 10GB of ram will result in a JVM heap size of 512 MB. On a 64-bit machine the only option is ti deinstall the broker, add memory and reinstall the broker. Performance increases just a bit.... VMware stated by phone to increase the vCPU's from 2 to 4.... this part I cannot find in any documentation saying so.

René

0 Kudos