Chris_Nodak
Enthusiast
Enthusiast

Allow user to choose protocol grayed out

Jump to solution

We are using linked clone pools and we noticed today that a few of our pools do not allow the end user to choose a different protocol other than the default. When looking at the settings for the pool, the option to all users to choose protocol is grayed out. We can change the default protocol, but want to be able to have the option to switch between PCoIP and Blast. Any ideas why this is grayed out and how to fix it?

See attached screen cap for reference.

0 Kudos
1 Solution

Accepted Solutions
Chris_Nodak
Enthusiast
Enthusiast

I came up with a solution that appears to be working.

1. Disabled provisioning at the vcenter level.

2. Backed up my ADAM database

3. Connected to the ADAM database with ADSI Edit, found the pool in question and modified the Attribute: pae-ServerProtocolAllowOverride from 0 to 1. 

4. Closed ADSI edit. Went back to Horizon admin, re-enabled provisioning. In the pool settings the option was still grayed out but it was set to allow the user to change, however still didn't get the option to change the protocol in the client until I changed the default for the pool from PCoIP to Blast, and then changed it back. Now the end user can choose which protocol they want to use in the Horizon client.

View solution in original post

0 Kudos
8 Replies
sjesse
Leadership
Leadership

What version are you on, there was a bug at one point if you had the HTML option turned on you couldn't change that, I think its fixed in recent versions

0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

We upgraded to 7.13 from 7.11 this past weekend. I can't confirm if this was grayed out prior to the upgrade however. One pool is defaulted to PCoIP another to Blast. I can change the default, but for troubleshooting purposes for end users it's nice to be able to change the protocol on the fly.

I did find this article but the commands he mentions no longer appear valid in PowerCLI. https://gpozd.blogspot.com/2019/02/horizon-pool-options-are-grayed-out.html

0 Kudos
sjesse
Leadership
Leadership

Do you have html enabled, if not enable it, or disable it and reenable it if your already have it enabled.

0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

Sorry not sure what you mean? Do you mean disable HTML access through the browser or disable HTML Blast? I'm looking at the settings and not finding the HTML setting at all.

0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

Actually if I recall HTML has to be chosen during agent install and I'm pretty sure it wasn't on this pool. I was looking at other pool settings and the option to change the setting for allowing the user to choose protocol is grayed out regardless of what that setting currently is. So on pools where it's enabled, I can't disable it either.

Tags (1)
0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

Well I just tested and can connect to the VM via HTML no problem.

The issue is we have an end user who is trying to connect to her VM, which is defaulted to PCoIP but it won't reliably connect. We were going to switch her to Blast, which when tested, works fine on other pools I have access to. There's something wrong with her personal laptop that isn't allowing the PCoIP connection. Not sure where to go from here. I don't want to change the default protocol for the entire pool to Blast since I have about 20+ other users connected with no issues via PCoIP.

0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

After some more digging I realized that all my pools that use the NVIDIA GRID GPU for 3D renderer the protocol option is grayed out. I have one pool that doesn't use GRID that isn't grayed out and can be changed.

0 Kudos
Chris_Nodak
Enthusiast
Enthusiast

I came up with a solution that appears to be working.

1. Disabled provisioning at the vcenter level.

2. Backed up my ADAM database

3. Connected to the ADAM database with ADSI Edit, found the pool in question and modified the Attribute: pae-ServerProtocolAllowOverride from 0 to 1. 

4. Closed ADSI edit. Went back to Horizon admin, re-enabled provisioning. In the pool settings the option was still grayed out but it was set to allow the user to change, however still didn't get the option to change the protocol in the client until I changed the default for the pool from PCoIP to Blast, and then changed it back. Now the end user can choose which protocol they want to use in the Horizon client.

0 Kudos