daniel_topp1
Contributor
Contributor

All Desktop Sources are currently busy

My problem is this, I can't seem to get the View client or the web client to connect to the desktops created in View Composer. The agent seems to be configured correctly when I log on to the machines via the VC interface the View interface shows the clients conneced and the user logged in. But when I try to go through the client I get the generic error message. My event log is showing this:

(SESSION:8BE124DE19A92AFBA42DBD66A7A912C6;A31BC480D431AF45FDE7024D469DE178) User foo\someone could not be allocated a machine for desktop Test - reason: All sessions are busy - check for extraneous console logins

My event log from View says that and the following:

(SESSION:8BE124DE19A92AFBA42DBD66A7A912C6;A31BC480D431AF45FDE7024D469DE178) SERVERS_OVERLOADED:Pool:CN=Test,OU=Applications,DC=vdi,DC=vmware,DC=int;USER:foo\someone;USERDN:CN=S-1-5-21-666323215-3762835912-3947363992-310278,CN=ForeignSecurityPrincipals,DC=vdi,DC=vmware,DC=int;

Both the VC and the VMView Server are virutal machines with 2 gigs of ram on them on sep ESXi hosts. I figure its something simple that I am missing. Also the View server has all the Hosts and VM's DNS info in the Host file.

Tags (2)
0 Kudos
8 Replies
etamir
Enthusiast
Enthusiast

maybe a shot in the dark...

1. make sure the desktop vm is logged off from any user.

2. go to "Desktop Sources" under Desktop and Pools, and check who is the user that has been allocated to this desktop source. Try to login with that specific user and see if that works. (this will not help if the pool is non-persistent since then it has no meaning...)

Let me know if it helped...

Smiley Happy

daniel_topp1
Contributor
Contributor

Thanks for the help. But that didn't work either.... This might be the only stumbling block to getting this all set up and working.

0 Kudos
etamir
Enthusiast
Enthusiast

I see...

Few more Q:

1. Is this on a specific pool type? do you experience the issue with individual desktop as well? or different pool type?

2. Do you have this problem with Vista/XP or both?

0 Kudos
daniel_topp1
Contributor
Contributor

This happains both on the Non-Persetant and Persent Pools for desktops.. Setting up a Terminal Services Pools works fine with no problems.

We are currently only using XP. Vista is not an issue yet.

I did move the View Server to a phyiscal machine. Currently My next step will to be to move the vritaul center server to a physical server to see if that fixes the problem.

Thanks

Dan

0 Kudos
prutter
Enthusiast
Enthusiast

In the View Mngr does it show a user as being connected to that machine next to the column that has the status or is that still blank?

daniel_topp1
Contributor
Contributor

Ok I would like to thank you guys for your help with this... I finnaly figured out the problem. There was a local GPO setting disabling Remote Desktop/Terminal Services on the VM. Turned that on and they came right up. Its always the small things.

Thanks Again All

Dan

0 Kudos
arjunvenkatrama
Contributor
Contributor

I have the same issue. In my case, the pool is a persistent, manual desktop pool. The View Administrator Console shoes all desktop sources as "Ready" and assigned to users. I can ping the desktops by hostname from the client machine. I can even RDP into the machines by hostname using the Microsoft RDP client. However, when i try to connect using the client, I get the error "All Desktop Sources for this pool are currently busy"

Any suggestions?

0 Kudos
arjunvenkatrama
Contributor
Contributor

Fixed by resetting the Desktop Sources from the View Administration Console

0 Kudos