VMware Horizon Community
pmarchiori
Contributor
Contributor

4.5: LC Customization fails but no Agent error

Hi all,

newly installed View 4.5 with VC; Windows 7 Linked-Clone pool. Everything goes well, W7 get KMS activated, joins domain, until after the "Customizing" stage, desktops being provisioned go straight into "Error" state with message:

Composer agent initialization state error (9): Failed to relocate disposable (waited 0 seconds)

D:\TEMP\vmware-viewcomposer-ga-new.log tho shows no errors, only INFO and DEBUG lines. Relevant part (after QuickPrep PostSync script output) of it:

2010-09-23 16:32:27,857 DEBUG WaitableManagerWin32 - http://WaitableManagerWin32.cpp, 87 Updating callback for event RegistryChangeMonitor, key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList (00000178)

2010-09-23 16:32:27,857 DEBUG WaitableManagerWin32 - http://WaitableManagerWin32.cpp, 90 adding callback for event RegistryChangeMonitor, key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList (00000178)

2010-09-23 16:32:27,857 DEBUG WaitableManagerWin32 - http://WaitableManagerWin32.cpp, 179 Dispatching callback for event WaitableManagerInternal (00000128)

2010-09-23 16:32:27,857 INFO Ready - http://Ready.cpp, 145 Triggering the profile list monitor event

2010-09-23 16:32:27,857 INFO SvmStateMachine - http://SvmStateMachine.cpp, 74 Queing an event

2010-09-23 16:32:27,857 DEBUG WaitableManagerWin32 - http://WaitableManagerWin32.cpp, 179 Dispatching callback for event RegistryChangeMonitor, key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList (00000178)

2010-09-23 16:32:27,857 INFO Ready - http://Ready.cpp, 192 User profile keys need not be saved.

2010-09-23 16:32:42,748 INFO CSvmGaService - http://svmGaService.cpp, 370 user logon.

2010-09-23 16:32:42,748 INFO Ready - http://Ready.cpp, 192 User profile keys need not be saved.

2010-09-23 16:34:58,498 INFO CSvmGaService - http://svmGaService.cpp, 376 user logoff.

2010-09-23 16:45:35,337 INFO CSvmGaService - http://svmGaService.cpp, 370 user logon.

2010-09-23 16:45:35,337 INFO Ready - http://Ready.cpp, 192 User profile keys need not be saved.

No search helped me yet. Hope some of you will... thanks in advance!

Reply
0 Kudos
1 Reply
DataSolutionsGr
Contributor
Contributor

I also experienced the same error at one of our sites. It was occurring with a Windows XP virtual machine. The image used to be the parent in a View 4.0 linked clone pool. The VMware View Agent had not been updated, once updated the problem was solved.






Follow on Twitter - @dsga | http://twitter.com/dsga | Blog - http://www.data-solutions.com.au/blog

Twitter: @dsga | Blog: www.data-solutions.com.au/blog
Reply
0 Kudos