kegwell
Enthusiast
Enthusiast

Installing Linux on Mac M1 (ARM)

Jump to solution

I see this question has been asked in multiple places, but I'm not finding a solution.  I had been running Ubuntu server on my Mac M1 (ARM) successfully up until about a month ago.  The VM won't even boot now that the kernel has been upgraded.  I can still install older versions of Ubuntu with kernel > 5..4 without an issue.  However any linux distribution I try installing now (Ubuntu, RH, Fedora, SUSE, etc) all fail to boot with the new kernel.  Even my once working VMs are now failing to boot with the new kernel, so I've had to edit the bootloader and go back a kernel version.

I was under the impression the latest kernels supported Mac M1/Fusion, but even with the latest Ubuntu ARM ISO (22.04) it fails to boot.

1. Is anyone else experiencing this?
2. If so, have you found a solution?

I'm running the latest version of Fusion, build 19431034.  Thoughts?

0 Kudos
2 Solutions

Accepted Solutions
Technogeezer
Champion
Champion

This is a well known problem - there are many posts here about it. Linux kernel developers made a change with that renders newer kernels unbootable on the Tecb Preview. 

There is currently no solution to the problem, only a workaround for a VM that worked before and now doesn’t after the kernel update, and you’ve found it: is to use the GRUB menu to boot  into an earlier kernel . It’s highly recommended if you do that to also flag the kernel packages so that they will not update again while this issue persists. 

we are awaiting an update to the Tech Preview so this will no longer be an issue. VMware has said nothing official about when that will come but the product manager has hinted at demoing something in June - hope an updated tech preview will follow. 

View solution in original post

0 Kudos
Technogeezer
Champion
Champion

And new installers have a new kernel which has the issue - because the distribution maintainers  are including these new kernels in all new installers as a security upgrade. There is.no work around for that other than trying to find older installation ISOs that don’t have the updated kernel. 

View solution in original post

0 Kudos
2 Replies
Technogeezer
Champion
Champion

This is a well known problem - there are many posts here about it. Linux kernel developers made a change with that renders newer kernels unbootable on the Tecb Preview. 

There is currently no solution to the problem, only a workaround for a VM that worked before and now doesn’t after the kernel update, and you’ve found it: is to use the GRUB menu to boot  into an earlier kernel . It’s highly recommended if you do that to also flag the kernel packages so that they will not update again while this issue persists. 

we are awaiting an update to the Tech Preview so this will no longer be an issue. VMware has said nothing official about when that will come but the product manager has hinted at demoing something in June - hope an updated tech preview will follow. 

0 Kudos
Technogeezer
Champion
Champion

And new installers have a new kernel which has the issue - because the distribution maintainers  are including these new kernels in all new installers as a security upgrade. There is.no work around for that other than trying to find older installation ISOs that don’t have the updated kernel. 

0 Kudos