jloc0
Contributor
Contributor

FreeBSD 13.1 and mouse support

Jump to solution

For those who don't know, FreeBSD runs great on fusion preview and has been the only OS I've had much success with since the preview existed. Recently, I decided I wanted to see how FBSD's GNOME support was, so I started up a new vm and installed everything. Switched from wayland to Xorg and I can get gdm and gnome-session going but no matter what I do, there's no mouse. The packages are all installed, and I get nothing. I have mouse enabled in rc.conf, but when testing with bsdconfig, it never works on any choices. I've seen online you need to make a Xconfig file and if I do that, x11 stops running on a reboot. With no Xconfig, gdm and gnome-session work, but again, no mouse. I've tried running 'vmware-user' when logged into GNOME and still nothing.

I'm at a loss, if anyone has some advice, I'd love to hear it.

0 Kudos
2 Solutions

Accepted Solutions
k_ronny
Enthusiast
Enthusiast

You can try to load the USB mouse driver in "/boot/loader.conf":

ums_load="YES"

View solution in original post

k_ronny
Enthusiast
Enthusiast

oh, at the moment freebsd (efifb) uses the resolution specified by the EFI environment. Try adding to your "/boot/loader.conf":

efi_max_resolution="1920x1200"

But not every resolution is available.

View solution in original post

5 Replies
k_ronny
Enthusiast
Enthusiast

You can try to load the USB mouse driver in "/boot/loader.conf":

ums_load="YES"

jloc0
Contributor
Contributor

Wow, thank you so much! It was that easy!

0 Kudos
jloc0
Contributor
Contributor

Well mouse is working great now, but I can't get vmtoolsd to work, desktop always stays at 1064x768, I get no options or the desktop size matching like vmware has always done. open-vm-tools is installed, I've enabled a bunch of stuff in rc.conf but it doesn't seem to help. I'll look at it again tomorrow with fresh eyes.

0 Kudos
k_ronny
Enthusiast
Enthusiast

oh, at the moment freebsd (efifb) uses the resolution specified by the EFI environment. Try adding to your "/boot/loader.conf":

efi_max_resolution="1920x1200"

But not every resolution is available.

jloc0
Contributor
Contributor

Interesting, having messed around with resolutions on real hardware with that I had thought there wasn't modes that high available through the loader. Interesting. And again, thank you, that works excellently!

0 Kudos