Technogeezer
Champion
Champion

Anyone have any luck with Ubuntu 5.15 kernels?

Jump to solution

I have had no luck getting any of the Ubuntu 5.15 kernels working. They all seem to hang at boot after displaying they're mounting the initramfs. The 5.14 kernels through 5.15.21 work fine.

Anyone had any luck getting these kernels to work?

0 Kudos
1 Solution

Accepted Solutions
Mikero
Community Manager
Community Manager

I updated the bug over at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1953671 as well.

We are able to boot by adding:
acpi=force

to: GRUB_CMDLINE_LINUX_DEFAULT
in: /etc/default/grub
Such that the full line reads:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

 

-
Michael Roy - PM/PMM: Fusion & Workstation

View solution in original post

32 Replies
Technogeezer
Champion
Champion

Fat fingered.  I meant to say that I've had no issues with 5.14 kernels through 5.14.21, not 5.15.21.....

0 Kudos
Soepie
Contributor
Contributor

Updated my Fedora 35 workstation install and is running fine on kernel 5.15.

Tags (1)
0 Kudos
Technogeezer
Champion
Champion

And my Open SUSE Tumbleweed VM  just updated to 5.15 and it’s working fine. It’s just that I’m having a devil of a time with Ubuntu and getting 5.15 kernels to boot. 

0 Kudos
Soepie
Contributor
Contributor

Will have a try when I get the time. Always fun to experiment with these kind of things.

Any Ubuntu version or specific (not an Ubuntu guy so not sure what versions run which kernel).

0 Kudos
myitcv
Contributor
Contributor

Ditto. Any pointers here greatly appreciated, because 5.14 is now EOL.

0 Kudos
Technogeezer
Champion
Champion

Something Ubuntu is doing is broken because 5.15 kernels work fine with OpenSUSE Tumbleweed and Fedora 35. 

0 Kudos
Technogeezer
Champion
Champion

@Soepie I’ve tried the 5.15 kernels with both 21.10 Impish and 22.04 Jammy (recent builds). Same hang on boot on both of them. 

myitcv
Contributor
Contributor

I've just raised https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1953671 to see if we can move this along from the Ubuntu side.

0 Kudos
Technogeezer
Champion
Champion

Thank you very much.

There's obviously something wonky with Canonical's build since SUSE and Fedora builds of 5.15 work just fine.

0 Kudos
cyprienlaplace
VMware Employee
VMware Employee

So first you need to disable wayland. Then I was able to boot with graphics by adding `acpi=force` to the linux command in grub.

0 Kudos
Mikero
Community Manager
Community Manager

I updated the bug over at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1953671 as well.

We are able to boot by adding:
acpi=force

to: GRUB_CMDLINE_LINUX_DEFAULT
in: /etc/default/grub
Such that the full line reads:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

 

-
Michael Roy - PM/PMM: Fusion & Workstation
Technogeezer
Champion
Champion

I can also confirm that this change allows me to install and boot the 5.15.14 kernel on 22.04 Jammy.

Thank you @cyprienlaplace and @Mikero .

0 Kudos
myitcv
Contributor
Contributor

Fantastic, thank you so much for the fast workaround!

0 Kudos
stevekul
Contributor
Contributor

This is great - but how/where do I add this? How do I get to /etc/default/grub in the MacOS finder? do I open a .vdmk? 

Thanks!

We are able to boot by adding:
acpi=force

to: GRUB_CMDLINE_LINUX_DEFAULT
in: /etc/default/grub
Such that the full line reads:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

0 Kudos
Mikero
Community Manager
Community Manager

When the Live CD installer is still booted, the installation path is `/target/` 

So you'd edit the file at /target/etc/default/grub

-
Michael Roy - PM/PMM: Fusion & Workstation
stevekul
Contributor
Contributor

Thanks! Can I fix my existing VM this way?

0 Kudos
Mikero
Community Manager
Community Manager

Sort of... The VM runs when it's in this state, so if you enabled the sshd service you can just ssh into it and change it manually.

Otherwise, you'd have to manually mount it, and then you would choose the mount point (/media/mount or something).

If it's a blank VM, it's probably easier to just start over and make the change after the installation but before the guest reboots.

 

-
Michael Roy - PM/PMM: Fusion & Workstation
Technogeezer
Champion
Champion

Don't forget to run 'update-grub" as a superuser after you make the changes to /etc/default/grub so that the changes get reflected in the boot partition.