mssblinq
Contributor
Contributor

22H2 ARM - Windows 11 audio problem

Jump to solution

After updating to newest Tech Preview 22H2 (ARM), audio in Windows 11 during video playback is sometimes not working. When I play a video (MPC or WMC) some of the times audio is not working and a Fusion error message saying "Error in creating sound stream. Playback may not work." Same on new installed Windows 11 with tools and on the old Windows 11 without any changes (including vHW).

0 Kudos
1 Solution

Accepted Solutions
Mikero
Community Manager
Community Manager

This is a known issue unfortunately. We have some work to do on the sound device.

My apologies for not having it in the 'Known Issues' section. 

Internal folks (@higarg): I filed bug 3002482 on this. 

-
Michael Roy - PM/PMM: Fusion & Workstation

View solution in original post

18 Replies
higarg
VMware Employee
VMware Employee

Hi,

Can you please share your system details like Host OS Version, system type (x86 or arm) and we shall look into this and get back to you.

0 Kudos
mssblinq
Contributor
Contributor

Running on MacBook Air M1 (2020).

Windows 11 Arm64, 21h2 build 22000.832

This is the ARM board so i will not post Intel problems 🙂

0 Kudos
Technogeezer
Virtuoso
Virtuoso

Actually this forum is not exclusively about the ARM version of the Tech Preview. It’s just that the TP was only out for APple Silicon Macs until today. 

0 Kudos
Mikero
Community Manager
Community Manager

This is a known issue unfortunately. We have some work to do on the sound device.

My apologies for not having it in the 'Known Issues' section. 

Internal folks (@higarg): I filed bug 3002482 on this. 

-
Michael Roy - PM/PMM: Fusion & Workstation
mssblinq
Contributor
Contributor

ok. Thanks

0 Kudos
bzilli
Contributor
Contributor

I've had luck setting the sample rate of the virtual audio device to 44,100Hz in the guest, instead of the default 48,000. It seems macOS internal speakers use this sample rate by default. It also solved some crackling issues I was having.

dpasirst
Contributor
Contributor

Thank you @bzilli - I realize this post is for Windows but the same problem and thus fix / change worked for Fedora Linux as well.

0 Kudos
Soren-the-BoSS
Contributor
Contributor

So? Is there a working fix for this problem? Or, at least something that makes the aerror no longer show up? The annoyance for me is that the aerror takes away the focus from the vm which makes working with vmware fusion and a screenreader impossible.

0 Kudos
bzilli
Contributor
Contributor

From my experience, the 44,100Hz setting seems to reduce the frequency of the error and definitely improves audio quality, but your experience has been similar to mine in that the error does still appear from time to time.

Until they fix the issue, the following seems to resolve it more robustly, but it's very hacky and is of course not a permanent solution: you could try playing something inaudible in the background on the guest (e.g. a wav file with a constant tone of 18 Hz on loop) to keep the sound stream open. I imagine this would have unforeseen consequences on things like battery life, though.

I'd assume there's a better way to implement this (that is, forcing the sound stream to remain open all the time, perhaps some vmx file setting), but so far I haven't found it.

0 Kudos
Soren-the-BoSS
Contributor
Contributor

Thanks for the quick answer. I will try the second solution out and create an other post if it doesn't work.

0 Kudos
jmccormick00
Contributor
Contributor

How did you make that change in Fedora? I cant seem to find that setting

0 Kudos
Woodyanna
Contributor
Contributor

I really hope the sound problem is fixed before the official release. For people like me, who are totally blind and use screen readers, Windows will be unusable until it's fixed because almost every time the error pops up, the screen reader stops speaking. I assume the same is true for Linux.

0 Kudos
Mikero
Community Manager
Community Manager

The issue has been resolved internally.

I think there's some grace for users now if you just disable 'echo cancellation' the prompt doesn't happen nearly as much.
But we also did some code changes to stop the underlying issue from creating the prompt.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
dbaum22101
Contributor
Contributor

This is a serious bug for the visually

impaired customers!!!

we cannot use screen reader!!!!!!!

0 Kudos
Technogeezer
Virtuoso
Virtuoso

My expectation since  VMware is aware of the issue and has fixed it internally is that we should see the fix in the upcoming official next version of Fusion. They’re not spinning another version of the Tech Preview, so you’re going to have to wait another couple of weeks or so. 

mssblinq
Contributor
Contributor

Looks like if I disable input device (microphone) in Windows, audio output works without problems. On M1 Air.

0 Kudos
EvanKatz
Contributor
Contributor

I get the exact same continuously and endlessly repeating audio error message running the latest release of Windows 10 on Fusion Tech Preview on Ventura.  See the screenshot.

0 Kudos
Technogeezer
Virtuoso
Virtuoso

@EvanKatz this was noted as a known issue in the Tech Preview Testing Guide. It's not related to Ventura. As stated in other replies to this thread, VMware was aware of the issue and had it fixed in internal builds. Let's see if this goes away once Fusion 13 is released "real soon now". 

0 Kudos