VMware Cloud Community
mrose1120istar
Contributor
Contributor
Jump to solution

error when doing VCBMounter on new account

hi, i'm getting the following error when trying to do a backup with vcbmounter on a windows machine. It works as myself (domain user), but if I try it with a new vcbuser account which is added to the built in vcb role, I get this. I've even tried adding it to administrators and it still doesn't work

C:\>vcbmounter -h ny-vc. -u domain\vcbuser -p nottelling -m san -t fullvm -r C:\VMBackups\NY-WEBSENSE -a name:NY-LCSMobile

2008-12-08 13:07:38.982 'App' 5584 info Current working directory: C:\

2008-12-08 13:07:38.982 'BaseLibs' 5584 info HOSTINFO: Seeing Intel CPU, numCo

resPerCPU 1 numThreadsPerCore 2.

2008-12-08 13:07:38.982 'BaseLibs' 5584 info HOSTINFO: This machine has 4 phys

ical CPUS, 4 total cores, and 8 logical CPUs.

2008-12-08 13:07:40.013 'BaseLibs' 5584 info Using system libcrypto, version 9

0709F

2008-12-08 13:07:40.295 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Subject mismatch: VMware vs ny-vc.istarfinancial.com

2008-12-08 13:07:40.295 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: The remote host certificate has these problems:

  • The host name used for the connection does not match the subject name on the h

ost certificate

  • A certificate in the host's chain is based on an untrusted root.

2008-12-08 13:07:40.295 'BaseLibs' 5584 warning SSLVerifyIsEnabled: failed to

read registry value. Assuming verification is disabled. LastError = 0

2008-12-08 13:07:40.295 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Certificate verification is disabled, so connection will proceed despite the

error

Copying "[vm_NY-LCSMobile] NY-LCSMobile/NY-LCSMobile.vmx":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile/NY-LCSMobile.nvram":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-13.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-12.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-14.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-15.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-16.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware-17.log":

0%=====================50%=====================100%

**************************************************

Copying "[vm_NY-LCSMobile] NY-LCSMobile//vmware.log":

0%=====================50%=====================100%

**************************************************

2008-12-08 13:08:09.029 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Subject mismatch: VMware vs ny-vc.istarfinancial.com

2008-12-08 13:08:09.029 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: The remote host certificate has these problems:

  • The host name used for the connection does not match the subject name on the h

ost certificate

  • A certificate in the host's chain is based on an untrusted root.

2008-12-08 13:08:09.044 'BaseLibs' 5584 warning SSLVerifyIsEnabled: failed to

read registry value. Assuming verification is disabled. LastError = 0

2008-12-08 13:08:09.044 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Certificate verification is disabled, so connection will proceed despite the

error

2008-12-08 13:08:10.435 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Subject mismatch: VMware vs ny-vc.istarfinancial.com

2008-12-08 13:08:10.435 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: The remote host certificate has these problems:

  • The host name used for the connection does not match the subject name on the h

ost certificate

  • A certificate in the host's chain is based on an untrusted root.

2008-12-08 13:08:10.435 'BaseLibs' 5584 warning SSLVerifyIsEnabled: failed to

read registry value. Assuming verification is disabled. LastError = 0

2008-12-08 13:08:10.435 'BaseLibs' 5584 warning SSLVerifyCertAgainstSystemStor

e: Certificate verification is disabled, so connection will proceed despite the

error

2008-12-08 13:08:10.544 'blocklist' 5584 warning Could not renew disk lease.

2008-12-08 13:08:13.857 'App' 5584 warning Need to re-acquire lease for snapsh

ot-4453[vm_NY-LCSMobile] NY-LCSMobile/NY-LCSMobile.vmdk after failed lease renew

al (Attempt #1).

2008-12-08 13:08:14.825 'blocklist' 5584 warning Could not renew disk lease.

2008-12-08 13:08:14.825 'BlockList' 5584 error

Converting "C:\VMBackups\NY-WEBSENSE\scsi0-0-0-NY-LCSMobile.vmdk" (compact file)

:

0%=====================50%=====================100%

**************************************************

2008-12-08 13:08:17.810 'vcbMounter' 5584 error Error: Failed to export the di

sk: I/O Operation failed

2008-12-08 13:08:17.810 'vcbMounter' 5584 error An error occurred, cleaning up

...

Deleted directory C:\VMBackups\servername

I have plenty of space, and as I mentioned it works with my user account. Thanks!

Reply
0 Kudos
1 Solution

Accepted Solutions
apatel1
Enthusiast
Enthusiast
Jump to solution

Thanks for the log. It looks like it's not even getting through any of the download. What rights does this user account have on the VCB proxy itself? I'd try giving it Administrator rights on the proxy to see if that helps any.

Hope that helps! Please help me out by marking my response as "helpful" or "correct" if you feel that it was useful!

-Amit

Please help me out by awarding points for a "helpful" or "correct" response if you feel that it was useful! -Amit

View solution in original post

Reply
0 Kudos
8 Replies
eagleh
Enthusiast
Enthusiast
Jump to solution

You may try 1>use "vcbuser" instead of "istarfinancial\vcbuser" and 2>make sure "vcbuser" got enough permissions on VI-Client GUI.

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!
mrose1120istar
Contributor
Contributor
Jump to solution

i tried just using vcbuser and with no change.. it definitely has the right permissions, but it appears to not be permissions based as if i run it under my name (domain admin) it runs fine, but even if I put this user in the VMWare administrators group, it still fails with the same. I'm running the latest release of VCB( double checked the download site).

Reply
0 Kudos
mrose1120istar
Contributor
Contributor
Jump to solution

so i can add the user to the VC Server's "administrators" group, adn it works then, but obviously that gives it too many rights. Any ideas??

Reply
0 Kudos
apatel1
Enthusiast
Enthusiast
Jump to solution

Hi, can you try running the command again with the additional switches "-L 6" (this is the most verbose logging level) and post the log?Also, at what level in your VirtualCenter tree are the rights applied to this new account?

Hope that helps! Please help me out by marking my response as "helpful" or "correct" if you feel that it was useful!

-Amit

Please help me out by awarding points for a "helpful" or "correct" response if you feel that it was useful! -Amit
mrose1120istar
Contributor
Contributor
Jump to solution

I've tried to add it at all levels, attached is the log.

Reply
0 Kudos
apatel1
Enthusiast
Enthusiast
Jump to solution

Thanks for the log. It looks like it's not even getting through any of the download. What rights does this user account have on the VCB proxy itself? I'd try giving it Administrator rights on the proxy to see if that helps any.

Hope that helps! Please help me out by marking my response as "helpful" or "correct" if you feel that it was useful!

-Amit

Please help me out by awarding points for a "helpful" or "correct" response if you feel that it was useful! -Amit
Reply
0 Kudos
mrose1120istar
Contributor
Contributor
Jump to solution

so i contacted VMWare support, I had to add it at the "hosts and clusters level" not the Datacenter level, whoops... also for some reason my built in VCB Role didn't have the correct rights, under provisioning under virtual machine it was set to Allow read only disk access isntead of allow download.

thanks all!

Reply
0 Kudos
eagleh
Enthusiast
Enthusiast
Jump to solution

"it has to be under "hosts and clusters" level". hmmm, good to know. thanks.

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!
Reply
0 Kudos