brettcarr1
Enthusiast
Enthusiast

vsphere client on Windows 7 rc

Has anybody managed to get the vsphere client working on Windows 7, it installed fine but when I try and login to an esx server, I get an error:

Error Parsing the server "192.168.1.10" "clients.xml" file Login will continue contact your system administrator

Clicking ok gives me another error

The type initializer for "VirtualInfrastrcture.Utils.HttpWebRequestProxy" threw an exception

Clicking ok returns me to the login dialogue.

I know Windows 7 isn't released yet but as it's so close I would of thought vmware would of tested it.

Brett

0 Kudos
211 Replies
jamesrichter
Contributor
Contributor

x86. I understand there is a workaround, but it seems crazy that VMware isn't support a client OS with their vSphere client. I understand it's a .NET issue with a .dll but that doesn't seem something un-correctable.

0 Kudos
tnolan
Contributor
Contributor

This did not work on my system. I'm running Windows 7 Ultimate and the only 'compatibility' option was a wizard where I did select XP SP3, and it still generates the same error message for clients.xml.

If you use my powershell script it will set this up for you and you

wont have to use compatibility mode which is slow in my experience.

Hope this helps!

-- Tom Nolan http://tinyint.com
0 Kudos
DoranceMC
Contributor
Contributor

thanks for solve that problem :smileygrin:

0 Kudos
fcollin
Contributor
Contributor

Unfortunately XP mode is only possible if your computer supports intel VT or the AMD equivalent. If for some reason your bios locks that option or you have an older computer this is not a valid workaround.

0 Kudos
JasonVITE
Contributor
Contributor

I had to edit the Vsphere.cmd to this:

SET DEVPATH=C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\lib

"C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe"

Not sure if that was any big difference but if you need to simply copy and paste that might help... Thanks a lot for the original post

0 Kudos
firefox111
Contributor
Contributor

I am running Win7 retail. vsphere client still does not run on Win7. "Error parsing the server "192.168.0.240" "clients.xml" file...."

0 Kudos
amitjoshi
Contributor
Contributor

Fernando's fix works perfectly on Windows 7 Enterprise x64. Thanks for your help!

0 Kudos
PFSpfs
Contributor
Contributor

I get a:

VpxClient

VpxClient has stopped working

Windows can check online for a solution to the problem.

View problem details

What can I do????

0 Kudos
firefox111
Contributor
Contributor

Thank you. But how do I get to that fix? Where is it?

0 Kudos
ric9887
Contributor
Contributor

I have found that I had 2 different versions of system.dll

2.0.50727.4927

2.0.50727. 3053

I found that version 2.0.50727. 3053 worked, while the other version still gave the parsing problem for clients.xml. No idea exactly where each version came from, but if you arehaving problem even after setting the environment variable, changing the config file and copying the file, then check the exact version of this file.

I can not believe they have not released a version of Infrastructure manager which works nicely with Windows 7.

0 Kudos
pviqueira
Contributor
Contributor

It is incredible that vmware has not yet released a version for windows 7. maybe the best option is to think in Xen or HypeV.

0 Kudos
DSeaman
Enthusiast
Enthusiast

Yes I find it amazing VMware is so slow to support W7 and 2008 R2. They RTM'd MONTHS ago and have been available to businesses since August. 95% of the VMs are Windows so more timely suport from the market 'leader' should be expected.

Derek Seaman
0 Kudos
tsd_david
Enthusiast
Enthusiast

vCenter Server 4 Update 1 released!! (both with ESX 4, ESXi 4, vSphere Client)

0 Kudos
emm1
Contributor
Contributor

Do you have an URL where I can download the client?

0 Kudos
Innuendo
Contributor
Contributor

Doesn't seem to fix anything so far, can someone confirm or infirm ?

Just upadted my client and nothing changes, still failing to launch without modification.

Plain sad from VMware if you ask me. Very sad.

0 Kudos
Mr-E
Contributor
Contributor

Hi, I have downloaded the new client this morning and installed onto a recently (Monday) rebuilt Windows 7 x64 build and I have to say, everything appears to be working so far. I have received no error pop-ups while connecting either to VC 2.5 or to and ESXi 4 (free) box.

Will continue playing and come back with any issues experienced.

Regards

Mr-E

0 Kudos
Photubias
Enthusiast
Enthusiast

I had a Windows 2008 R2 x64 with the reported error and did NOT perform the workaround.Instead, I uninstalled vSphere Client and installed build 208111 from vSphere Client.

Everything is working like a charm, and this thread may be locked now.

I'll try to directly link the url here but if it does not work, please try to download ESXi from vmware.com and in the download page choose the new vSphere client binary.

Link

Thanks for rewarding answers!

Greetings,

Photubias

0 Kudos
Innuendo
Contributor
Contributor

Ok, my issue surely is due to the way I installed it.

I tried to install it above the "modified" installation, which doesn't work then.

So to make it work, you surely have to unistall everything (let's hope it's enought) or even rebuild your system (!!!).

By the way my bad, seems to be working with 7 / 2008 R2 now.

0 Kudos
djswarm
Contributor
Contributor

Cudos to Fernando for the fix.

Running win7x64 ult final

A number of people seem to be having some of the problems I had so here are my notes and end files...

If you got the "program stopped" error take the quotes off the devpath path.

For some reason it wants absolute paths.

I just pulled the dll off my xp box after loading the appropriate .net - nothing special.

now I don't have to keep running vclient out of virtual box - ah, the irony Smiley Happy

0 Kudos
RichardWest
Contributor
Contributor

To those that are having problems and installing update 1, and have used Fernado's fix, be sure to go to the vSphere client launcher directory, open the VpxClient.exe.config file in a text editor and add a REMOVE the

...

<runtime>

<developmentMode developerInstallation="true"/>

</runtime>

</configuration>

This config file remains on your system even after an uninstall, so you must remember to make this change, otherwise you will still continue to receive error messages when you start the client.

0 Kudos