brettcarr1
Enthusiast
Enthusiast

vsphere client on Windows 7 rc

Has anybody managed to get the vsphere client working on Windows 7, it installed fine but when I try and login to an esx server, I get an error:

Error Parsing the server "192.168.1.10" "clients.xml" file Login will continue contact your system administrator

Clicking ok gives me another error

The type initializer for "VirtualInfrastrcture.Utils.HttpWebRequestProxy" threw an exception

Clicking ok returns me to the login dialogue.

I know Windows 7 isn't released yet but as it's so close I would of thought vmware would of tested it.

Brett

0 Kudos
211 Replies
jdiekert
Contributor
Contributor

After turning on development mode i get the message "Configuration system failed to initialize", when trying to log in.

Any Idea why?

Thanks in advance.

Jens

0 Kudos
D_Rock
Contributor
Contributor

I found that if I use this in command prompt it works fine, other users of Windows 7 Professional RTM with UAC off may find this useful as well:

setx devpath "c:\program files (x86)\vmware\infrastructure\virtual infrastructure client\launcher\lib\"

SETX is a more robust version of the set command.

0 Kudos
JetJaguar
Contributor
Contributor

Awesome. Worked for me on Win7 Enterprise 64 RTM. I just have to right click the short cut and run it as administrator.

Thank you very much for the instructions!

0 Kudos
GTMK
Contributor
Contributor

Hmm. I don't get it to work, I always get the message "Configuration system failed to initialize". I have a W7 Enterprise x64, the system.dll is from a W2K3 R2 (x86). Any ideas?

Georg.

0 Kudos
GTMK
Contributor
Contributor

I've got it... there were (probably through cut & paste) some non-ASCII characters in the VpxClient.exe.config...

Georg.

0 Kudos
mbell98
Contributor
Contributor

Thanks so much for the solution, Fernando!

0 Kudos
tsd_david
Enthusiast
Enthusiast

How you launch the vSphere Client? it should launch with parameter shown before.

As well as use batch file to launch it.

0 Kudos
mbell98
Contributor
Contributor

The client gets launched by executing the .cmd file. It sets the path then calles the client executable.

0 Kudos
tcutts
Enthusiast
Enthusiast

I am hoping Vmware can release a product update to fix this issue. I'm not excited about changing around dll's and making changes to .net that I might forget to change back later....

You're not changing the system installed .Net. You're only giving the vSphere client its own local copy of the older .Net DLL, so it's a fairly safe change, isn't it?

Tim

0 Kudos
D_Rock
Contributor
Contributor

You're not changing the system installed .Net. You're only giving the vSphere client its own local copy of the older .Net DLL, so it's a fairly safe change, isn't it?

Tim

Very true, I just copied the good DLL from my vista box to the lib directory. Once that's done the scripts tell vmware to use the dll that's located in the lib directory. Very safe indeed, but I do wonder if VMware can repackage that same DLL with the next version, or if they will have to rewrite the client all together. Probably safer to make a new one i guess.

0 Kudos
AsherN
Enthusiast
Enthusiast

It's not a rewrite, likely just a recompile against the new DLLs.

0 Kudos
ftubio
Contributor
Contributor

I am hoping Vmware can release a product update to fix this issue. I'm not excited about changing around dll's and making changes to .net that I might forget to change back later....

You're not changing the system installed .Net. You're only giving the vSphere client its own local copy of the older .Net DLL, so it's a fairly safe change, isn't it?

Tim

This is correct, provided you use the batch file to set the environment variable. Other posters in this thread mention setting DEVPATH in control panel, which does work too, but this means that any .NET program could potentially load assemblies from the vSphere client Lib folder. Of course, for this to happen they would have to have development mode enabled as well.

Incidentally, I got tired of having an additional command prompt window open every time I used the client so I now use a slightly modified batch file from what I originally proposed.

SET DEVPATH=%ProgramFiles%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib

SET PATH="%ProgramFiles%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\";%PATH%

start /B VpxClient

It now launches the application and then goes away.

Fernando Tubio

0 Kudos
jefferai
Contributor
Contributor

As Troy says this does not work on Windows 7 yet, and I would not expect it to / complain as Windows 7 is not yet RTM anyway.

Same problem on Windows 7 RTM.

Consider this a complaint.

0 Kudos
brettcarr1
Enthusiast
Enthusiast

If anybody is interested unsurprisingly the same problem also exists on Windows Server 2008R2.

Also does anybody know if/when VMWARE will support customisation of Windows Server 2008R2 from a template, I tried building as 2008 and applying a customisation but it doesn't work.

Brett

0 Kudos
Davita
Contributor
Contributor

I tried the procedure above and at first it didn't work. I'm running Windows 7 RTM 32-bit.

The procedure above works, however, before you install the vSphere client, right-click on the installation executable and select troubleshoot compatibility. It will recommend that it runs in Windows XP SP2 compatibility mode. Apply those changes, then run the executable. Once you do that and it installs, perform the steps above and it will work.

0 Kudos
D_Rock
Contributor
Contributor

I'm curious Davita, can you use the host update utility with this procedure. The "developer mode" method did not eliminate any host update utility problems i came accross. I still get a few errors when I try to run it that are similar to the errors I received before I configured my client for developer mode.

0 Kudos
Davita
Contributor
Contributor

I haven't tried using the host update utility yet, I'm sure someone else may have already tried using it with Win7 - hopefully they can chime in and shed some light on it for you.

0 Kudos
AndersNolberger
Contributor
Contributor

I have now successfully started the host update utility on a Windows 7 Ultimate 64 RTM. I followed the instructions for the vSphere Client and copied the .config file to the update folder and renamed it to VIUApp.exe.config and and also changed the relevant rows in the cmd file. Everything appears to work. I have not done an update since my ESXi is up to date but no errors when downloading or adding host.

Thanks for this workaround!

0 Kudos
emm1
Contributor
Contributor

Why does it take VMWare so long to update their products? (N)

0 Kudos
DSeaman
Enthusiast
Enthusiast

Given they released an update for vCenter to fix a class A subnet problem, which I think is pretty rare, the glaring problem of W7/2008R2 still exists. Pretty unresponsive if you ask me. The fix can't be THAT difficult!

Derek Seaman
0 Kudos