brettcarr1
Enthusiast
Enthusiast

vsphere client on Windows 7 rc

Has anybody managed to get the vsphere client working on Windows 7, it installed fine but when I try and login to an esx server, I get an error:

Error Parsing the server "192.168.1.10" "clients.xml" file Login will continue contact your system administrator

Clicking ok gives me another error

The type initializer for "VirtualInfrastrcture.Utils.HttpWebRequestProxy" threw an exception

Clicking ok returns me to the login dialogue.

I know Windows 7 isn't released yet but as it's so close I would of thought vmware would of tested it.

Brett

0 Kudos
211 Replies
Tonym89
Contributor
Contributor

you need to edit the VpxClient.exe.config file

<?xml version="1.0" encoding="utf-8"?>

<configuration>

<system.net>

<connectionManagement>

<clear/>

<add address="*" maxconnection="8" />

</connectionManagement>

</system.net>

<appSettings>

<add key = "protocolports" value = "https:443"/>

</appSettings>

<runtime>

<developmentMode developerInstallation="true"/>

</runtime>

</configuration>

Also insure that you have the .Net "system.dll" from a Non Win7 machine

I have attached both my config and the dll file in a zip file here

Place the config file in your C:\Program Files\Vmware\Infrastructure\Virtual Infrastructure Client\Launcher folder

Create a new folder called Lib in the folder noted above and place the dll file in this

Edit your system properties and create a new 'Environment Variable" Name it "Devpath" with the value of C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib

Reboot and you should be good to go

0 Kudos
kdonofrio
Contributor
Contributor

Tony - Thank you very much! This worked out perfectly! I originally had the launcher folder in another location, having vc2.5 installed. I removed all other stuff, reinstalled vsphere client, and then followed your instructions. Works perfect! Thank you again

0 Kudos
Tonym89
Contributor
Contributor

Like the others before me who helped me, I am glad that I could help you

0 Kudos
brosy
Contributor
Contributor

Just a note, no reboot required (tested on Windows 7 x64 build 7100)

0 Kudos
degustator
Enthusiast
Enthusiast

This trick with dll and config file works like a charm. Thanks Fernando!

But does somebody have any idea on how to allow it run non-elevated?

(hope I don't desire way too much...)

0 Kudos
ftubio
Contributor
Contributor

But does somebody have any idea on how to allow it run non-elevated?

You are welcome, but I'm not sure what you mean. I am running the vsphere client non-elevated. This is on Windows 7 (32-bit).

Fernando Tubio

0 Kudos
ftubio
Contributor
Contributor

Wait! I just thought of something that might make a difference. I'm still using the beta (not the RC) on this machine. I believe that there are changes in UAC since the beta and that might explain the difference.

Fernando Tubio

0 Kudos
degustator
Enthusiast
Enthusiast

You are welcome, but I'm not sure what you mean. I am running the vsphere client non-elevated. This is on Windows 7 (32-bit).

Oh, that's my fault. I used to enter "set" command in my elevated command prompt session, so it was effective only for applications launched from there. And someone in previous posts here also adviced to run the vSphere client elevated. So I made a wrong conclusion that your solution require it.

Now I defined the environmental variable globally for my user profile and non-elevated client works perfeclty. For reference, I'm running 64-bit version of Windows 7 RC (build 7100).

0 Kudos
Gary_Gunderson
Contributor
Contributor

Works as advertised!

Thanks for the information.

0 Kudos
Supal2009
Contributor
Contributor

That worked for us!

Thank you.

0 Kudos
blackg
Contributor
Contributor

since there is a workaround now has anyone from vmware said whether they are working on a patch or new client that is W7 compatible?

0 Kudos
VampyreUK
Enthusiast
Enthusiast

Hi,

I tried the solution (on Win 7 64Bit) and I can't even modify the file, I lack premissions to access the folder when I try to save.

EDIT: Got round that but I can't make it work:

1. Placed the DLL in new folder "Lib+"

2. Edited the VpxClient.exe.config as specified:

<?xml version="1.0" encoding="utf-8"?>
* <configuration>*
* <system.net>*
* <connectionManagement>*
* <clear/>*
* <add address="" maxconnection="8" />
* </connectionManagement>*
* </system.net>*
* <appSettings>*
* <add key = "protocolports" value = "https:443"/>*
* </appSettings>*
* <runtime>*
* <developmentMode developerInstallation="true"/>*
* </runtime>*
* </configuration>*

3. Created the VpxClient.cmd

SET DEVPATH=C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib

"C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe"

Notes:

  • Tried both as two lines and 1, also tried with "%Program Files%" and "%Program Files (x86)%" to replace "C:\Program Files (x86)":(

  • Tried the client running on XP (dual boot system) and it works fine.

Kyu

0 Kudos
Innuendo
Contributor
Contributor

Just a note from my experience : if I don't put the "+" sign at the end of the DEVPATH environnemnt variable, it doesn't work.

Also, deactivate compatibility mode and use normal mode.

I use a system.dll file from a XP SP3 installation, 32 bit and it works like a charm on my x64 Seven box...

Be VERY careful with copy/paste of the config file, symbol " can be misinterpreted by your system, just retype ALL OF THEM or errors may occur.

Regards

0 Kudos
Actional
Contributor
Contributor

Thanks for the tip, which seems to be working for most users.

unfortunately it doesn't work for me.

I'm not on Windows 7, I'm actually on Vista

You might be wondering why then I have this issue?

This issue only surfaces when I connect from home through VPN (Cisco IPSEC), the same laptop in the office doesn't have any issues connecting.

So I guess this is more of a networking issue then a MS issue, which most of us are quick to put the blame on.

I appreciate any feedack that could lead to getting this working over VPN.

Thanks

0 Kudos
DanWood
Contributor
Contributor

Works like a champ for Windows 7 (32bit) running on ESXi 4.

0 Kudos
RogerG781
Contributor
Contributor

It doesn`t work for me

I used the files from the zip archic from , but wenn i start the VSphereVI.cmd. The programm will closed with error, "The programm doesn`t work".

The Error came up from Windows 7.

What can i do?

Thanks

0 Kudos
ftubio
Contributor
Contributor

I used the files from the zip archic from , but wenn i start the VSphereVI.cmd. The programm will closed with error, "The programm doesn`t work".

The Error came up from Windows 7.

What can i do?

Thanks

I can't tell with certainty what the problem is but it's very likely that the DEVPATH environment variable is not set correctly. Make sure that it points to the folder where you placed the System.dll file. Keep in mind that you should not enclose the path in quotes when setting the environment variable.

You might want to troubleshoot this by opening a command prompt, changing the current directory to the location of the vSphere client launcher, setting the environment variable manually, and then executing VpxClient.exe.

(for Windows 7 x64 use %ProgramFiles(x86) instead)

C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher> SET DEVPATH=%ProgramFiles%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib

C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher> VpxClient.exe

If that fails, at the command prompt type cd %devpath% to change the current directory using the environment variable. This should change the directory to the location of the updated System.dll file. If it doesn't, then it means you have not defined it correctly,

Hope that helps.

Fernando Tubio

0 Kudos
SommerR
Contributor
Contributor

That got it going - good work - Thanks!!! - Russ

0 Kudos
ITFocus
Contributor
Contributor

I also had same problem, and Windows7 RX x64, this worked for me..

0 Kudos
yannara
Contributor
Contributor

Fernando's instructions did'n work for me (I might have done something wrong). What is the status, when there will be officially Win7 compatible VM-client?

0 Kudos