vsphere 6.7 LSI raid card, can't get drive status

Jump to solution


I have this server setup at home:

SuperMicro X10SLL-F

Intel Xeon E3-1241 v3

32GB 3CC 1600

LSI 8708EM2

2x Velociraptor 10k 300gb RAID 1

4x WD Red 2TB Raid 5

I was running Vsphere 6.0 since a long time, and I decided to go over 6.7. Installation worked fine, I have access to everything, all is working... Except 2 things:

1. I can't get my LSI 8708EM2 (detected as a 1078) to show drive status

2. Can't get my Storage Manager to access disk info or rebuild raid.

When I was on vSphere 6.0, I was able to see my drive status (and veeam one could alert me), and with my WIndows VM, I had LSI MSM and I was able to configure the raid card.

So what I did:

Install SAS driver I was using in version 6 --> not working

Installed the SMIS I had  --> not working

Installed lastest SMIS  --> not working

Disabled the Firewall --> not working

I have no idea what else I can do. I know it's an old card, but I got it for cheap. Any idea how can I get this fixed?


70 Replies

I have a 9260-8i and I have not updated from 9.5U1 because of the lack of legacy RAID controller support with newer versions of vSphere.

Can someone please chime in and tell us if 9.7U3 and LSA for 9260-8i provides enough features to actually be viable? Does it monitor and send email alerts about disc & battery issues? Can it maintain (discharge/recharge) the BBU like MSM does with 9.5U1?

0 Kudos

Hi freeloader3,

Mine is: Version:, for Win x86 and x64. And the latest/current version is LSA has several option during installation, and I chose 'Gateway....'. Once done, double-click the LSA icon on your Win-Desktop, and your browser will open a new tab to launch the service. Then input the right IP to discover your ESXi host and it will show up if all is in order. Use your ESXi host's username/password to login.

Please make sure the IP addresses of both of your ESXi host and Windows Workstation are in the same IP segment, e.g., If there is a need, you may add an line in your Windows 'hosts' file(C:\Windows\System32\drivers\etc\):

YourESXiHostName     192.168.1.x


Thank you so much.

Downloaded the latest ( from and it works fine without any magic.

0 Kudos
Hot Shot
Hot Shot

Excellent!   I upgraded from 6.5U1 to 6.7U3 this past weekend and found that I couldn't check my raid device status.  I downloaded the LSA software, installed it on Win7 (yes it installs on Win7 even though it doesn't list it as supported), and it all just worked with the stock lsi_mr3 and lsiprovider drivers that were installed by the 6.7U3 update process.   Looks like all the functionality that was present in the old Megaraid Storage Manager is here, and the bonus is that there isn't a fight each time getting the software to find the ESXi server. 

P.S.  Has anyone gotten the email alerts to work?  I can't seem to get it to send any emails.  When I click test, it just comes back and nothing happens.  I run my own email server and I can verify that it saw nothing.  If I deliberately put in a bad IP address it says that it can't send the mail, so it's doing something. 


0 Kudos

I got email working just fine.

Test it again while monitoring with sysinternals might shed some light on it...

0 Kudos

Hi everyone,

i tried this CIM Provider

Latest SMIS Providers

once i test to take Disk down > vCenter alerts but there is no Sensor.  Need to go to the Host Client view. there i see an Storage Section. 


that looks usefully

what i'am trying now is Remote checking Health through the  wbem sfcbd Service.

but i don't find the correct CIM Classes

those worked with 6.0.  Zero Info back with 6.7

VMware_SASSATAPort = Controller Ports

VMware_StorageVolume = Raid Status

VMware_StorageExtend = Disk Online Status

Anyone may knows the right CIM Classes to get above checked remotely?

Best regards


0 Kudos

I was able to get this working today.  I thought I would share exactly what I did:

I started with an older SuperMicro-based system (X9DRH-7TF) with an embedded LSI 2208 RAID chip.  I installed VMware-provided ESXi 6.7U3.

After installation, I enabled SSH and used it to install StorCLI 1.23.02 (from via the following command:

  esxcli software vib install --no-sig-check -v /vmfs/volumes/storage/path/vmware-esx-storcli-1.23.02.vib

I don't think StorCLI is necessary for the rest, but I *really* like having it, so I installed it first!  Once installed, I tested it with the following command:

  /opt/lsi/storcli/storcli show ctrlcount

It showed one controller.  Great!

There were reports that nothing needed to be installed on the ESXi side, but this is *incorrect*.  I found that if I next installed the LSI Storage Authority on a VM, it would not work.  I was able to discover the ESXi system, but when I tried to log in I got Error 65537:  Login failure.

Actual next step:  make sure you have lsiprovider installed.  First, verify that you don't, from SSH command line:

  esxcli software vib list | grep lsi

There were several LSI lines (for the drivers) but there was *not* one for lsiprovider.  Fine, now we'll install one.  The latest I could find was 500.04.V0.73-0002 from  I installed it with the following command:

  esxcli software vib install --no-sig-check -v /vmfs/volumes/storage/path/vmware-esx-provider-lsiprovider.vib

It installed, but requires a reboot to continue.  After rebooting and logging back in via SSH, I reran the vib list command above and saw lsiproviders.

I then installed the LSI Storage Authority software on a Windows VM.  That VM was on the same subnet as my ESXi box, and the ESXi host was automatically added to LSA.  One problem I had:  the computer name it uses is what it gets from its query of ESXi.  In my test environment here, that name does *not* resolve.  So connecting to that host did not work.  However, I used the Manual Discovery with the ESXi system's IP address and was able to connect to it successfully.

From there, I was able connect to the host using proper credentials from the ESXi side (e.g. root, and the password I used to install ESXi).  I could see the controller and array status, make changes, etc.

As an aside:  I tried to make the Email alert portion of LSA work.  If I used our actual production SMTP server, testing the email configuration would *crash* the LSA interface!  If I used a test (internal) SMTP server it would work, but that doesn't do me that much good.  I'm not real thrilled with the idea of the LSA being responsible for monitoring and alerting anyway:  I use Zabbox and storcli to check on the status of the array instead.

In any case, this will get a brand-new ESXi 6.7U3 box with an LSI 2200-series controller connected to LSA so you can see the status of your array as well as make changes.  I hope it helps save someone some time...


THIS worked for me. Thank you. I can now at least half manage my 9260-8i. More importantly I can silence alarms.

However, I found out the hard way although I can re-enable the alarm in the GUI it is not possible to silence the alarm from the LSI Storage software interface.

I get an error about an unknown object when I try. Instead I had to do this via StorCLI - so I'm very glad I installed this.

For anyone else in this situation wondering; from the ESXi shell; /opt/lsi/storcli/storcli /c0 set alarm=off

If anyone has been able to do this, I'm all ears.

0 Kudos


Dell C2100
ESXi 6.5u3
AVAGO Megaraid SAS 9270CV-8i

p.s. by the way, C2100 works at ESXi 7.0u3 (supported NIC installed additionaly) with options:
AllowLegacyCPU=True systemMediaSize=small
for now, not tested with VMs and LSI Storage Authority Software
planing a soon.

Tags (1)
0 Kudos

a latest LSA LSI Storage Authority Software:
did not find ESXi 6.5u3

some information in LSA_Windows_readme.txt:

5. ESXi (Until ESXi6.5) contains a provider class VMware_UserAuthorizationService which provides single method called CheckPermission() to get the permission particular user has. This could be read, readwrite or view
From ESXi 6.7 onwards VMWare has deprecated this service and VMware_UserAuthorizationService class is not available
Impact : LSA doesn’t have a known method to check user permission on ESXi 6.7 and this will impact LSA Login
Workaround : LSA shall avoid making the check for user permission and consider user has read-write permission

0 Kudos

confirmed, RAID management works at ESXi 7.0U3:

Dell Sequoia C2100 8 CPUs x Intel(R) Xeon(R) CPU L5520 @ 2.27GHz
LSI MegaRAID SAS 9270CV-8i
I350 Gigabit Network Connection


p.s. don't forget to add parameter for every new VM:
Key: monitor.allowLegacyCPU
Value: true

0 Kudos