VMware Cloud Community
amishera
Contributor
Contributor
Jump to solution

vsish - md5 signature mismatch

I have ESX 4.1 build 324795. I collected the vsish from vmdev website. Now after setting up the vsish, if I want to run it from console I get this error message:

Error: error: md5 signature mismatch with running vmkernel built on _Unknown_ (my build date: May 18 2010 16:42:32)

What is the problem here? Please help.

Reply
0 Kudos
1 Solution

Accepted Solutions
lamw
Community Manager
Community Manager
Jump to solution

This occurs when the vsish version built for a particular version of ESX does not match the version on your host, I know in the past I've seen something similiar and needed to get the right version from VMware. vsish utility for ESX is not generally available and if you contact VMware, they should have a special debugging RPM package which maps to each ESX releases. I'm not sure if that is what you downloaded, but the error basically stats there's a miss-match and won't run.

View solution in original post

Reply
0 Kudos
2 Replies
lamw
Community Manager
Community Manager
Jump to solution

This occurs when the vsish version built for a particular version of ESX does not match the version on your host, I know in the past I've seen something similiar and needed to get the right version from VMware. vsish utility for ESX is not generally available and if you contact VMware, they should have a special debugging RPM package which maps to each ESX releases. I'm not sure if that is what you downloaded, but the error basically stats there's a miss-match and won't run.

Reply
0 Kudos
amishera
Contributor
Contributor
Jump to solution

you are right my dear friend. I downgraded the ESX version and it is working fine. Thanks

Reply
0 Kudos