VMware Cloud Community
neoishere
Contributor
Contributor

vmware-cmd register command half-complete

Hi,

I am using ESX4i server version 4.0.0 Build 219382. I have vSphere CLI 4.0 Update 1 installed on an Ubuntu machine.

I routinely copy a VM over to ESX4i server and use vmware-cmd register command to add the VM to the inventory. This has been working flawlessly for last so many days but today when I run:

/usr/bin/vmware-cmd -v -H -U root -P "password" -s register "[datastore3] restore-may3/restore-may3.vmx"

API Version: 4.0

register() =1

( I also see STDOUT has this:potentially harmless line "Warning: XML::LibXML compiled against libxml2 20632, but runtime libxml2 is older 20631")

After this I observe that :

1. The vSphere client shows a successful "Register virtual machine".

2. vSphere client's inventory view doesn't show the new VM.

3. Any attempt to again register(both using vmware-cmd or using vSphere client) fails with this message:

Fault string: The specified key, name, or identifier already exists.

Fault detail: AlreadyExists

And if I unregister using vmware-cmd and:

a. try registering using vmware-cmd , it goes back to same half-complete state.

b. try registering using vSphere client, it works as expected.

Any clue to this puzzle?

Thanks!

Tags (4)
0 Kudos
1 Reply
neoishere
Contributor
Contributor

Forgot to add that unregister command was working fine from that ubuntu machine.

Update- I tried running vmware-cmd from a different machine(CentOS) and it worked fine. I did this a few times and came back to my original ubuntu machine and now it is working from that machine too. I can unregister and register just fine.

So, it doesn't look to be an vCli installation issue on Ubuntu. Can it be a timing/state related issue with the ESXi server?

0 Kudos