thhg
Enthusiast
Enthusiast

vmkapi dependency

ESXi 6.7 fully patched

Was trying to update an LSI driver and got the following message :

esxcli software vib install -v /tmp/lsi-mr3-7.707.11.00-1OEM.

670.0.0.8169922.x86_64.vib --no-sig-check

[DependencyError]

VIB Avago_bootbank_lsi-mr3_7.707.11.00-1OEM.670.0.0.8169922 requires vmkapi_2_5_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB VMware_locker_tools-light_10.2.0.7253323-8169922 requires esx-version >= 6.6.0, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

Where do I find the updated vmkapi ?

Thanks,

Steve

Tags (1)
0 Kudos
3 Replies
daphnissov
Immortal
Immortal

If you're trying to update an existing VIB, you're using the wrong command line. It should be esxcli software vib update -n file.vib

0 Kudos
thhg
Enthusiast
Enthusiast

Still no joy ... here are 2 examples

esxcli software vib update -n /tmp/lsi-mr3-7.707.11.00-1OEM.670.0.0.8169922.x86_64.vib

[Exception]

Use of -n/--vibname requires use of -d/--depot.

Please refer to the log file for more details.

esxcli software vib update -v /tmp/lsi-mr3-7.707.11.00-1OEM.670.0.0.8169922.x86_64.vib --no-sig-check

[DependencyError]

VIB Avago_bootbank_lsi-mr3_7.707.11.00-1OEM.670.0.0.8169922 requires vmkapi_2_5_0_0, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

0 Kudos
anurag2189
Enthusiast
Enthusiast

Try using -f (force) option inline to vib install command

esxcli software vib install -v /tmp/lsi-mr3-7.707.11.00-1OEM.

670.0.0.8169922.x86_64.vib  -f --no-sig-check

0 Kudos