karl047
Contributor
Contributor

vmWare 7 : install i40e driver for intel x700 Family

Jump to solution

Hi,

I try to find a way to install i40e driver for Intel network adapter x710… All what I found are the i40en drivers with a native support…

Is it possible to install these drivers under ESXi 7 ?

0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

I doubt it, but maybe another user knows a workaround.
It may also be an option to post your question at https://community.sonicwall.com/

From https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-esxi-vcenter-server-70-release-notes.html

 

  • Deprecation of VMKLinux

    In vSphere 7.0, VMKLinux driver compatibility has been deprecated and removed. vSphere 7.0 will not contain support for VMKLinux APIs and associated VMKLinux drivers. Custom ISO will not be able to have any VMKLinux async drivers. All drivers contained in an ISO must be native drivers. All currently supported devices which are not supported by native drivers will not function and will not be recognized during installation or upgrade. VCG will not show any devices not supported by a native driver as supported in vSphere 7.0.

André

 

View solution in original post

6 Replies
a_p_
Leadership
Leadership

Please don't mind me asking, but what's wrong with the driver that comes with ESXi 7.0 by default?

André

0 Kudos
karl047
Contributor
Contributor

it’s needed for installing a firewall-Software with SR-IOV support

Is it possible to get the drivers or not???

0 Kudos
a_p_
Leadership
Leadership

There are drivers available which support SR-IOV.

Please find your specific network adapter at https://www.vmware.com/resources/compatibility/search.php?deviceCategory=io&details=1&keyword=x710&p... to see if this one is supported.

André

0 Kudos
karl047
Contributor
Contributor

thank you for your reply…

I ask you again, if there is a chance to get i40e (not i40en) driver installed on ESXi 7 …

https://www.sonicwall.com/techdocs/pdf/nsv-series-on-vmware-7-0-getting-started-guide.pdf#page45

I think that they work with another version of ESXI (6.7?), but however I can‘t getting installed on the system, because the driver has the native version…

I read that the inbox driver are not supported on ESXi 7, only the native one…

then again, because the community has surely more experience with it: ist it possible or not?..

Thanks…

0 Kudos
a_p_
Leadership
Leadership

I doubt it, but maybe another user knows a workaround.
It may also be an option to post your question at https://community.sonicwall.com/

From https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-esxi-vcenter-server-70-release-notes.html

 

  • Deprecation of VMKLinux

    In vSphere 7.0, VMKLinux driver compatibility has been deprecated and removed. vSphere 7.0 will not contain support for VMKLinux APIs and associated VMKLinux drivers. Custom ISO will not be able to have any VMKLinux async drivers. All drivers contained in an ISO must be native drivers. All currently supported devices which are not supported by native drivers will not function and will not be recognized during installation or upgrade. VCG will not show any devices not supported by a native driver as supported in vSphere 7.0.

André

 

karl047
Contributor
Contributor

exactly 👍🏼 & that what I read bevor… there is no support more for such drivers in ESXi 7, only the native one…

Thank you for the confirmation…

0 Kudos