GZRandy
Contributor
Contributor

vm can not power on due to "current connection state of the host"

I encontered an strange error, when  we try to power on a VM through a vCenter the error message appears :The operation is not allowed in the current connection state of the host, to solve the problem, you must disconnect the host, and connect it again, any one know why ?

0 Kudos
14 Replies
a_p_
Leadership
Leadership

It looks like the communication between the host and vCenter Server does not work properly anymore. If restarting the Management Agents (see http://kb.vmware.com/kb/1003490) does not help, you may need to restart the host.

ndré

0 Kudos
GZRandy
Contributor
Contributor

I do not think it is normal,the host should connected to vCenter correctly as they boot up

0 Kudos
a_p_
Leadership
Leadership

I agree with you. However, I had the same happen in vSphere 4.1 one time so far and only a host reboot resolved the issue.

André

0 Kudos
GZRandy
Contributor
Contributor

we have two esxi5 server for our lab, we boot it every day since September, I have meet this error about 10 times

0 Kudos
Virtualinfra
Commander
Commander

You mean rebooting the ESXi host every day.

1. Where are the VM's are placed in the Local datastore of ESXi host or a SAN datastore or NFS volume.

2. Are you rebooting vCenter server also. If so then there might be issue in reading the information in the database. where we might required to disconnect the host and reconnect it.

Thanks & Regards Dharshan S VCP 4.0,VTSP 5.0, VCP 5.0
0 Kudos

1. Suggesting you to check the recent tasks and active tasks of that particular ESX server. Someone may initiated Maintenance mode and host could trying to enter into maintenance mode.

    Select ESX. And go to summary > Active Tasks.

2. If there is nothing strange in the tasks, I recommend you to restart VC server service before powering on your VM.

Thanks,

Ganesh

~GaneshNetworks™~ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos
Tukker
Contributor
Contributor

Encountered the same problem.

Like Ganesh suggested is checked recent tasks of the ESX server, nothing special there...

enabled the ESX hosts' Maintenance mode.... then disabled maintenance mode... after that the guest started up as is should have..

no more problems since..

Hope this helps.

Greetz,

Tukker

0 Kudos
TronAr
Commander
Commander

I encountered this after a not clean vCVA shutdown. Restart of the vpxd service after a restart of the vpxa agent did the trick for me. Only restarting vpxa was no good. Restarting vpxd solved the issue only for a host that had already restarted vpxa, but the problem continued for another that had not.

Bumping into maintenance mode did not help.

-Carlos

0 Kudos
Guillain
Contributor
Contributor

Hi,

Already encountered and solved: disconnect and reconnect host Smiley Wink Have a funny virtualization

0 Kudos
SimonSun
Contributor
Contributor

Hi,

The same problem has occurred in ESXi 4.1. I do the following to solve to problem.

login to esx host


/etc/opt/init.d/vmware-vpxa stop


wait until the VM disconnected from the vSphere Client


/etc/opt/init.d/vmware-vpxa start

Simon

0 Kudos
rajeshcloud
Enthusiast
Enthusiast

I faced the same issue in my lab environment. Issue resolved me after restarting vcenter server services.

if you power off all the AD, SAN, ESXi and vCenter servers you will face this kind of issue. After power on the vcenter server, restart the vcenter server services once again, it will work.

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"
0 Kudos
bjm534
Enthusiast
Enthusiast

0 Kudos
BobbyMercer
Contributor
Contributor

Hi All,

SSH into the host

chkconfig usbarbitrator off

services.sh restart

Worked for me. Thanks for the posts.

0 Kudos
brentquick
Enthusiast
Enthusiast

If you are connecting to vCenter or (vCSA) then try connecting to the host directly and doing the start from there.

I had to reboot a host and did not shut down vCSA first (missed it) and I got this message.

Rebooted vCSA but while waiting connected directly to host and could start VM from there.

Enterprise Technology Geek and Converged IT Person. NC Triad VMUG Leader vExpert 2012-2013 Information Technology Expert
0 Kudos