RajuVCP
Hot Shot
Hot Shot

vSphere Web Client installation upgrade error 1714

Hi All,

I have been upgrading vSphere vCenter 5.5 from 5.1  all went well.

But today when i was upgrading vSphere client for one of the VC i got below given error.

-- Error 1714.The older version of VMware vSphere Web Client cannot be removed.  Contact your technical support group. --

Am first time seeing this error message , my other VC upgrade went well without any such error.

does any one you came across such error message, could you please let me know what steps you did to resolve the issue.

Thanks a ton in Advance.

Raju Gunnal VCP 4, VCP 5, VTSP 4, VTSP 5, ITIL V3 http://www.techtosolution.com
0 Kudos
8 Replies
Atul_gen
Enthusiast
Enthusiast

Which version you are using for vSphere vCenter 5.5 ? This issue is fixed in 55U1. We are not facing any issue in 55U1 build.

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos
nkrishnan
Expert
Expert

need little bit of clarity, are you trying to upgrade vSphere Client, but error is showing WebClient upgrade.

Are you using Simple Install option for upgrade or selected individual under custom install option provided in autorun screen.

--Nithin
0 Kudos
RajuVCP
Hot Shot
Hot Shot

@Atul_gen am using VMware vCenter Server 5.5 U1b this version.

@Nithin Krishnan sorry for typo i am upgrading WebClient only. and i am using Custom install.

Raju Gunnal VCP 4, VCP 5, VTSP 4, VTSP 5, ITIL V3 http://www.techtosolution.com
0 Kudos
nkrishnan
Expert
Expert

If its a new upgrade, then its expected to work seamlessly. Can you please attach the upgrade log files available in temp folder.

Is it failed / error message came after the file copy started.

In side note: you can try by uninstall webclient and reinstall new version (5.5U1b), it doesn't remove any configuration apart from custom SSL Certificate if deployed.

--Nithin
0 Kudos
RajuVCP
Hot Shot
Hot Shot


the existing version running on it is 5.1 am running the 5.5 U1B.. i completed vsphere client, SSO, Inventory services, vCenter service.

But while runnign webclient i am getting that error 1714.

can you given upgradation log file location.

Raju Gunnal VCP 4, VCP 5, VTSP 4, VTSP 5, ITIL V3 http://www.techtosolution.com
0 Kudos
nkrishnan
Expert
Expert

upgrade logs will be in %temp% folder

--Nithin
0 Kudos
Atul_gen
Enthusiast
Enthusiast

Some time we face this problem because of setup env.


unregistration of Service and solution form SSO is not successful so it can be removed properly.

Workaround:

1) Workaround is to re-start the vsphere web clien installation after the vsphere web clien rolls back. The older solution user that remains after the workaround can be removed manually.

2.) Manually unregistered  solution (vsphere web client) from SSO then re-install vsphere web client  5.5. See the steps to unregistered sloution from SSO. VMware KB: Cannot remove obsolete solution users from the Lookup Service using the vSphere Web Clien... 

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos
RajuVCP
Hot Shot
Hot Shot

i checked in the logs nothing found specific to web client installation error.

any how i just raised VMware support request, in contact with GSS lets see what solution they can provide.

Raju Gunnal VCP 4, VCP 5, VTSP 4, VTSP 5, ITIL V3 http://www.techtosolution.com
0 Kudos