rb78
Contributor
Contributor

vSphere 6.7 Web Client - Browser settings not saved + Auth Plugin not working

Jump to solution

Dear all,

 

I got this week several feedbacks that Windows Chrome users in our company have 2 problems.

1. The users cannot login via auth plugin. Last week it works - this week not. It looks like the screenshot. Last week it works.

I googled around and tried all the common solutions but no one works. I tried the following:

  • Cleanup complete browser cache with restart of browser
  • Reinstall VMware Auth Plugin
  • Restarted the "VMWare CIP Message Proxy Service"
  • Added the certificate "https://vmware-plugin:8094"  to the trusted certificate 

Nothing works. With other Browsers like Opera, Edge it works without any problems.

 

2. Some Windows Chrome users told me that the settings in Chrome are not saved, e.g DateTime Format, Dark Mode, last selected folder/VM. 

I tried to cleanup the browser cache to but it doesn't help.

 

Additional info:

  1. Used Chrome version: 107.0.5304.88
  2. Used vSphere Version: 6.7.0.51000
  3. Used Auth Plugin Version: 6.7.0.4882

 

Does anyone have any idea what the cause of these two issues could be?

 

Best regards


Rainer

0 Kudos
1 Solution

Accepted Solutions
rb78
Contributor
Contributor

Hey,

 

 

the solution is: Open https://vmware-plugin:8094 in Browser and enter "thisisunsafe". After this the auth plugin works without any problems.

 

Best regards


Rainer

View solution in original post

0 Kudos
5 Replies
Kinnison
Expert
Expert

Hi,


I can't answer the first question because I've never used the "Auth Plugin", to the second question, yes.


In short, certain settings such as dark mode are based on the account used by the user then stored in cookies on the computer used to access the infrastructure , thus every time the cookies are deleted, blocked or unsaved on that said computer then the latter (same thing if using a different "new" computer) has to re-set his preferences from the beginning.


Regards,
Ferdinando

0 Kudos
rb78
Contributor
Contributor

Hey,

 

 

the solution is: Open https://vmware-plugin:8094 in Browser and enter "thisisunsafe". After this the auth plugin works without any problems.

 

Best regards


Rainer

0 Kudos
bwernli
Contributor
Contributor

So for me it does not work. I have now tested it several times and it is not the plugin, but the Google Chrome version.
With Chrome 104 everything works fine. from Chrome 106 and higher, it asks at startup exactly 1 time whether you want to use the plugin. After that, the question never comes and it no longer works.
Only if you delete the complete UserProfile, it works again a single time.

Best Regards Bernhard

 

0 Kudos
jiri-hadamek
Contributor
Contributor

For me the same - first clean-run works OK and then (chrome 107) it simply doesn´t work.

0 Kudos
bwernli
Contributor
Contributor

Workaround:

\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome   

Add a DWORD (32 bit) Value named "ChromeRootStoreEnabled" to 0
Confirm the value by checking in the Chrome policy (chrome://policy/) you have the "ChromeRootStoreEnabled" policy value to 0 

Re-launch the browser and try the login.

 

Please note, the above workaround might not help in future versions of Chrome, as Google is planning to remove this policy (ChromeRootStoreEnabled) in version 111 which is not yet released, more details in https://chromeenterprise.google/policies/#ChromeRootStoreEnabled

Best Regards Bernhard

0 Kudos