ChopChe
Enthusiast
Enthusiast

upgrade from ESXi5 to ESXi5.1

Jump to solution

I would like to upgrade our ESXi5 hosts in an HA/DRS clusters from ver5.0 to ver5.1 but have been told that it would be "a bear" to do.   Also, have been told that to do this we would "have to" upgrade vCenter ver 5.0 to ver 5.1 (this was mandatory, I'm told).

Can anyone advise me on this information?   I have upgraded previous versions of ESX (3.5 to 4.0 to 4.1)without much difficulty and the hosts were all on HA/DRS clusters (just a matter or removing the hosts from the clusters.....but, here I'm told we have to create a new cluster to upgrade each host) AND that we can not do the host upgrade until vCenter was first upgraded to ver5.1.   While I think this is a good practice, I didn't think it was absolutely mandatory.

0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

No, no need for a new cluster. Provided your current vCenter Server installatin meets the requirements for the new version, you can upgrade directly from version 5.0 (see http://pubs.vmware.com/vsphere-55/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-55-upgrade... for details)

André

View solution in original post

0 Kudos
5 Replies
a_p_
Leadership
Leadership

In order to manage 5.1 hosts, your vCenter Server need to run on version 5.1 or newer. You will run into issues if you upgrade the hosts first. Please take a look at the VMware Product Interoperability Matrix for supported configurations.

Btw. if your hardware (hosts, storage, ...) supports vSphere 5.5, it might be a better option to upgrade to this version rather than to 5.1.

André

0 Kudos
ChopChe
Enthusiast
Enthusiast

Thanks.  Makes sense.  What about the information about setting up a whole new cluster in vCenter to move the host out of their existing clusters to upgrade them?  Is that truly necessary?

0 Kudos
blu60077
Enthusiast
Enthusiast

Upgrading vCenter 5.0 to 5.1 upgrade video

upgrading ESXi 5.0 5o 5.1 upgrade video

0 Kudos
a_p_
Leadership
Leadership

No, no need for a new cluster. Provided your current vCenter Server installatin meets the requirements for the new version, you can upgrade directly from version 5.0 (see http://pubs.vmware.com/vsphere-55/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-55-upgrade... for details)

André

View solution in original post

0 Kudos
ChopChe
Enthusiast
Enthusiast

Thanks very much.

0 Kudos