lewisma
Contributor
Contributor

syslog not configured for persistent storage

Jump to solution

I am running ESXi, 4.0.0, 261974 on a HP Blade BL35p server. Everything installed fine and all is working OK apart if i try to get to the console of the Host. I get the following message '* SySlog is not configured for persistent storage'

I have looked at the Syslog settings under Software/Advanced Settings and everything is at default for local and remote. The only thing listed is port 514 which i believe is default. I have 3 VM's running on the local disk and 2 VM's running on a iSCSI target. Does anyone know how i can get to the console of the host ?

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Take a look at this KB article: http://kb.vmware.com/kb/1016621

Rick Blythe

Social Media Specialist

VMware Inc.

View solution in original post

0 Kudos
6 Replies
admin
Immortal
Immortal

Take a look at this KB article: http://kb.vmware.com/kb/1016621

Rick Blythe

Social Media Specialist

VMware Inc.

View solution in original post

0 Kudos
ExpletiveDelete
Enthusiast
Enthusiast

Are you seeing any logs for the server at the specified location?? if not, doublecheck your settings. if a location is not specified, it will go local by default.

lewisma
Contributor
Contributor

Thanks for your reply, i have no location listed in any of the syslog fields other than the port number listing of 514. Do i need to configure the fields for local, i thought if it were left blank it would go to the default location

0 Kudos
ExpletiveDelete
Enthusiast
Enthusiast

514 is the correct/default PORT, but you must also specify a folder location - See step 5 for default location.

Per the KB article noted above:

To configure syslog for an ESXi host:

  1. In the vSphere Client inventory, click on the host.

  2. Click the Configuration tab.

  3. Click Advanced Settings under Software.

  4. Select Syslog in the tree control.

  5. In the Syslog.Local.DatastorePath
    text box, enter the datastore path to the file where syslog will log
    messages. If no path is specified, the default path is
    /var/log/messages.


    The datastore path format is
    </path/to/file> where the path is relative
    to the root of the volume backing the datastore.

    Example: The datastore path var/log/messages maps to the path / vmfs/volumes/storage1/var/log/messages.

  6. In the Syslog.Remote.Hostname text box, enter the name
    of the remote host where syslog data will be forwarded. If no value is
    specified, no data is forwarded.

  7. In the Syslog.Remote.Port text box, enter the port on the remote host where syslog data will be forwarded. By default Syslog.Remote.Port is set to 514, the default UDP port used by syslog. Changes to Syslog.Remote.Port only take effect if Syslog.Remote.Hostname is configured.

  8. Click OK.

lewisma
Contributor
Contributor

Thanks for your reply, however it doesn't seem to accept anything i type into this text field box, i have one local datastore which is named as the default Local Datastore, what do i need to enter into the text box for local syslog setting. Whenever i type in anything and select OK i can see the 'Update Option Values' message in the Recent Task list with a green circle and completed but when i go back into Advanced Settings the text box is blank.

0 Kudos
lewisma
Contributor
Contributor

I have now managed to do this but it's a little confusing as i want using the brackets. Thanks for your help.

0 Kudos