VMware Cloud Community
powers
Enthusiast
Enthusiast

server 2008 r2 vm console hanging

Have a freshly installed 2008 r2 server on 4.1 u1 and it has hung 4 times today. It was ok for a few days, but since installing exchange 2010 yesterday, it has started hanging.

It has hung twice when I was clicking the down arrow a few times on event viewer. This is potentially pointing to a vsphere display issue...The server still pings, and I can view the event viewer via another server. Can't get to services though. RPC error.

Can't rdp into the server, it sits on the welcome screen then times out after a while.

Had to change the video driver from the default SVGA installed with vmtools due to poor mouse performance in the vsphere client console.

The select OS when creating the vm was "Server 2008 r2 x64"

Could be many things, but I'm trying to rule out a vsphere problem. Advice muchly appreciated....

Have other vms running with no problems, 2003 vms, a few server 2008 vms, but no other 2008 R2 vms.

Reply
0 Kudos
7 Replies
Shakaal
Hot Shot
Hot Shot

Hi,

can you please run esxtop and go to disk mode by pressing d, check for DAVG value if it is more than 15 then there is an issue with underlying Storage.

Regards

Reply
0 Kudos
powers
Enthusiast
Enthusiast

Hi

It bounces around from 6, to 30. Rarely gets to 60, but then comes back down after a second or two.

I don't think its storage related though, otherwise I would have issues with other vms....... 

Reply
0 Kudos
Shakaal
Hot Shot
Hot Shot

Hi,

you are correct doesn't seems to be a storage issue occassional spikes are fine, what does the application and system events inside the Guest OS has to say when the issue happens do they have any error message or they are fine.

Regards

Reply
0 Kudos
powers
Enthusiast
Enthusiast

Nothing overly helpful...

Software protection service entered the stopped state

WinHTTP Web proxy auto-discovery stops and starts

A few exchange services are stopped (but that shouldn't stop me logging in via RDP, or explain the console freeze)

All the services set to automatic are running except a few exchange services and the software protection and user experience, which keep stopping. Netlogon service is running, which is usually the one that is stopped when RDP doesn't allow logins.

Reply
0 Kudos
raj196
Enthusiast
Enthusiast

Hi powers, If you dont mind could you please use hot and bold procedure mentioned below . It is sure exch2010 creating problem so please remove completely and instal one by one role to find out which role creating problem.

If at first you don't succeed; call it version 1.0"
Reply
0 Kudos
powers
Enthusiast
Enthusiast

Removing exchange is a last resort as it will leave a mess in Active directory :smileycry:

No link to the "hot and bold" procedure?

Reply
0 Kudos
powers
Enthusiast
Enthusiast

To update - changed the video driver, upped the video memory and been using RDP. No problems since.

Reply
0 Kudos