bgwallace
Enthusiast
Enthusiast

[msg.hbacommon.corruptredo] The redo log of 'Ubuntu-Server-000001.vmdk' is corrupted. If the problem

Hey all,

I'm running into an issue with one of the VMs on my ESXi standalone server (no vCenter).  I rarely use the snapshots feature (I think I remember why now), but the other day I decided to create one while performing an Ubuntu upgrade.  There was plenty of free disk space on the snapshots drive so I'm not sure how I could've run out of disk space.  However, at some point whenever I would try to power on the VM in the ESXi host Web UI client, I started to get the error below:

"The redo log of 'Ubuntu-Server-000001.vmdk' is corrupted. If the problem persists, discard the redo log."

My only option is to answer OK to the prompt.  The VM stops.  I start the VM again, I get the same error so I'm stuck here.  The error is confirmed by the following in vmware.log entry below:

[msg.hbacommon.corruptredo] The redo log of 'Ubuntu-Server-000001.vmdk' is corrupted. If the problem persists, discard the redo log.

I'm also informed in the Web UI of the need to consolidate disks which I have tried doing.  The consolidation process completes successfully in the Web UI but the snapshot VMDKs don't not go away (they remain in the snapshots directory) and I tried deleting all snapshots which did delete the snapshot files but again the snapshot VMDKs don't go away.

I have 4 VMDKs attached to this VM.  The one that the error is complaining about is unimportant so if I lose it that would be okay as the data on it is volatile and I can recreate it easily enough.  I need to make sure I don't lose the data on any of the other VMDKs though.

Would it be a good idea and safe to use the Web UI to remove the bad VMDK from the VM and then try to startup the VM again or could this cause the problem to then get passed onto the next VMDK?  I'm in the process of making backups of all of the VMDKs so I can test if needed.

I've moved all other VMs to a different datastore to give the datastore with the snapshots as much disk space as possible.  I haven't tried another consolidate disks since making more room.  I thought I would ask folks here first for recommended next steps first.

I've read the posts on the forums here which are similar to mine but I'm unable to determine the exact steps I need to proceed from here.  I also tried to use the following article but some of it is unclear so again I'm not sure what exactly I need to do from here.

https://kb.vmware.com/s/article/1006585

I'm attaching vmware.log, vmkernel.log, along with df command output and ls command output for the directories involved.  The site wouldn't let me upload Ubuntu-Server.vmx.  Is it prohibited and/or a bad idea to share this data?

I tried to think of anything folks would need to help but if I missed anything just let me know what you need and I'll get it.

Unfortunately this happened at the worst possible time, I'm in between backup systems and I don't have a good backup so I need to figure out how to recover this VM and all data if possible.

If not possible, I need help on what I need to do to get good clones of the VMDK files.  I don't do this sort of thing regularly especially with snapshots in the picture.  I'm not sure if I need to do something differently given that some of the VMDK files are in the snapshots directory away from the main VMDK for the disk.

Thank you so much in advance for your help.  I'm hoping someone out there can help me work through this predicament.

Best regards,

Brad

Tags (3)
0 Kudos
0 Replies