princox
Enthusiast
Enthusiast

[msg.cpuid.noLongmodeQuestionFmt;]

Jump to solution

Hello? Before deploying the vSphere in field, I tried to learn and get concepts of VMware.

Below is my current studying environment.

[Environment]

[PC] SAMSUNG, Core i5, 64-bit, 8 RAM, Winodws 7 Home Preminum Editon (Home OS)

[VMware] 8.0.0-build 471780

[ESXi] VMware-VMvisor-Installer-4.1.0.updated1-348481.x86_64.iso (It installed on VMware Workstation)

[ESXi Client] Windows XP Professional (32-bit). It installed on VMware Workstation .

[Problem]

Description : When I connected vSphere through client, and then Create Virtual Machine.

Windows XP Professional (32-bit) successfully installed as Host1

However, installing Windows Server 2008 R2 (64-bit) w/ SP2 encountered with below message.

msg.cpuid.noLongmodeQuestionFmt:This virtual machine is configured for 64-bit guest

operating systems. However, 64-bit operation is not possible.

This host does not support VT.

For more detailed information, see http://vmware.com/info?id=152.

Continue without 64-bit support?

error_112.JPG

1) Through the KB link, I checked the comparability via VMware-guest64check-5.5.0-18463.

check_passed.JPG

2) By using cpu-z, I checked my detailed cpu and mainboard information.

cpu.JPGMainboard.JPG

3) Checked the BIOS(CMOS) to support VT or not. Showed CPU VT (VT-x) Supported.

BIOS_captured.JPG

I would like to know...

1) CPU code name Sandy Bridage can not support VT so that I have got those message?

2) BIOS showed CPU VT (VT-x) Supported means it support other Intel CPU not Sandy Bridage?

3) In the message, if I select YES and keep install it, Windows Server 2008 R2 can not install?

I admitted that my enviornment is not server... With trial and error mind, I did buy computer(laptop) to know VMware and vSphere.

If someone know about this situation, please give me some advice for me.

Thanks in advance.

Warmest Regards.

Jeff

0 Kudos
1 Solution

Accepted Solutions
rajeshcloud
Enthusiast
Enthusiast

Hi jeff,

Select your Win2008 R2 machine..  Goto Edit options-----> Select CPU---> At Right Side--> Enable VT option.

I think it will helpful for you, lets try it.

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"

View solution in original post

0 Kudos
13 Replies
rajeshcloud
Enthusiast
Enthusiast

1. Have you enabled VT Technology in Your BIOS setting. Intel i5 processor support VT technology. But you should enable VT. Once you enabled VT. You wont get error msg.

2. while creating  ESX server in Workstation, enable VT option for VM

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"
princox
Enthusiast
Enthusiast

Rajeshcloud, Thanks for helpful answer for me.

1. Have you enabled VT Technology in Your BIOS setting. Intel i5 processor support VT technology. But you should enable VT. Once you enabled VT. You wont get error msg.

: I checked it again and in Advanced TAB, there is no option for enable/disable VT technology.

Read and heard from ppl, those option as kind of hidden or somehting. So that I sent mail to Samsung (Mainboard Manufacturer) to enable this funcetion.

Through your reply, I can see a big hope.. I will let you know the rusult soon.

2. while creating ESX server in Workstation, enable VT option for VM

: I tried to find this option in VMworkstation in ESX/ESXi virtual machine setting... But I helplessly could not find it.

Please kindly advise me find that one.

Many Thanks!!!

Jeff,

0 Kudos
rajeshcloud
Enthusiast
Enthusiast

Hi jeff,

Select your Win2008 R2 machine..  Goto Edit options-----> Select CPU---> At Right Side--> Enable VT option.

I think it will helpful for you, lets try it.

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"

View solution in original post

0 Kudos
princox
Enthusiast
Enthusiast

Rajeshcloud, thanks alot!!!!

I just about to boot ESX/ESXi server in VMwork Station...

All of sudden, the thing that happened yesterday in ESX/ESXi server come accross...

I've nerver experienced it.. but this message popped up yesterday when I closed the ESX/ESXi server in VMwork Station.

001_fragmented_vdisk.JPG

And followed message I tried to find [click Defragment]... But i can not find it.

Second priority... I don't know why fragmented virtual disk happended..

Virtual_Machine_Setting.JPG

Many Thanks!!!

You are really help me out! :smileygrin:

If you know this message please advise me to escape this situation.

0 Kudos
admin
Immortal
Immortal

Defragment is in the Utilities menu.

rajeshcloud
Enthusiast
Enthusiast

Yes defragment option is available in utilities. Thanks for giving  valuable points.

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"
0 Kudos
princox
Enthusiast
Enthusiast

Jmattson & Rajeshcloud thanks for your help.

I'd like to know why the disk has fragmented all of sudden. Let me know if you are available...

Frankly... I can't understand terms of fragment and defragment anyways.

Jeff.

0 Kudos
rajeshcloud
Enthusiast
Enthusiast

Hi jeff,

Read this article, May be low space of hard disk you are geting warning message like defragment virtual disk. if we do defragment the vm performance will be increase.

http://www.howtogeek.com/howto/31303/improve-vmware-vm-performance-by-defragmenting-virtual-disks/

Regards,Rajesh, if you found this or other information useful, please consider awarding points for "Correct" or "Helpful"
0 Kudos
princox
Enthusiast
Enthusiast

Jmattson & Rajeshcloud thanks for your help.

I tried to do it as below; actully two options.....but i got the same message T.T

cpu_option.JPG

failed.JPG

msg_2.JPG

Those brings me down.... Smiley Sad

VT-X.JPG

0 Kudos
admin
Immortal
Immortal

You need to enable virtualized VT-x/EPT for the ESXi VM under Workstation.  Go to VM->Settings->Processors and check the box next to "VIrtualize VT-x/EPT or AMD-V/RVI."

0 Kudos
princox
Enthusiast
Enthusiast

Jmattson, thanks for helping....

setting.jpg

But when the ESXi starting up, right-corner has messasge; neck is going down...

vmworkstation_msg1.JPG

Thanks alot! though

Jeff,

0 Kudos
admin
Immortal
Immortal

That's not the setting I was referring to.  If there is no checkbox for "Virtualize VT-x/EPT or AMD-V/RVI" then you need to upgrade your virtual hardware to Workstation 8.  That's done under VM->Manage->Change Hardware Compatibility.  Once you've done that, the checkbox should appear.

0 Kudos
princox
Enthusiast
Enthusiast

Hi, Jmattson.

As your guide, I did it successfully. Really thanks!!!

When I installed ESXi 4.1 in VMware Station 8, I chose the hardware comparability as VMware 6.5 - 7 or something.

After changed 8 newly, everything is under control.

Many Thanks!!!

Jeff D. LEE :smileygrin:

0 Kudos