Paul90
Contributor
Contributor

mixing ESXi 5.1/5.5 and ESXi 6 in one HA/DRS-cluster

Hello Community,

I´m sorry if this question is answered in another thread, but i used google and the community search and haven´t found an answer. Smiley Sad

Are there any known issues when mixing ESXi 5.5 and ESXi 6 hosts in one DRS/HA-cluster?

I know that we have to have a look at the virtual machines hardware versions (hardware version 10/11) and the VMware tools version (6) due to compatibility, but are there any other potential problems I´m not thinking of at the moment?

Is this a supported configuration for a longer time?

The background is that we have 10 hosts (all at ESXi 5.1 at the moment) and three of them are not supported to run ESXi 6, only 5.5U2 and will be replaced in the next year.

Thanks in advance for any answers!

Kind regards,

Paul

6 Replies
Nithy07cs055
Hot Shot
Hot Shot

Please see the supported version of Hardware and its manageability

VMware KB: ESXi/ESX hosts and compatible virtual machine hardware versions list

different version can be managed by ESXi6, CPU and Hardware family should be same, for a Vmotion requirement EVC should be enabled

and if you are using DVS make sure you are taking precautions while adding it to cluster ,

and from Vsphere point of view many new features are available, follow the useful guide for the adding it to cluster

Vmware vCenter server 6 and Vsphere 6 - New Features and enhancement

hdwarec.JPG

Thanks and Regards, Nithyanathan R Please follow my page and Blog for more updates. Blog : https://communities.vmware.com/blogs/Nithyanathan Twitter @Nithy55 Facebook Vmware page : https://www.facebook.com/Virtualizationworld
CoolRam
Expert
Expert

It's always not recommended to run cluster with the mix and match host.

If your hardware is not supported for 6.0 then run your environment in 5.1 or 5.5 only.

If this is the test environment then try to upgrade to 6.0 despite of your hardware support

If you find any answer useful. please mark the answer as correct or helpful.
0 Kudos
npadmani
Virtuoso
Virtuoso

never tried HA with hosts 5.5 and 6 together in a single cluster.

Should be OK I guess.

VMCP (Virtual machine component protection) cannot be enabled as it has requirement of having all the hosts in version 6.

Multi-vCPU FT will be troubled so you got to live with Legacy FT.

Please let the VMs be in Hardware version 10, that way failover will not be failing due to compatibly issues since you will be mixing 5.5 and 6 hosts.

Narendra Padmani VCIX6-DCV | VCIX7-CMA | VCI | TOGAF 9 Certified
0 Kudos
slivovics
Contributor
Contributor

You always have the choice to construct for your ESXi 5.5 hosts a separate farm under the same vCenter 6.

From there you can push out the ESXi 5.5 VMs to ESXi 6 , provided the EVC mode or Hardware CPU mode is equal or higher

on the new hosts.

As buying newer hardware has in nearly all cases an higher EVC mode, you can easily hot migrate VMs cross Cluster (from ESXi 5.5 to 6)

So in the end there is no need to sustain a mixed Cluster.

Anyhow at a certain stage the old ESXi 5.5 hosts , in the separate from ESXi6 hosts farm, could be upgraded.

Then of course your VMs or the most important ones are already sitting on your ESXi 6 cluster.

You could also decide to keep the ESXi 5.5 host always separate if they can't be upgraded and use them as a Test and/or Dev repository.

In such case you have a consolidated view (single pane view) of your datacenter / site. Other tools like VMware View, vRealize and or SRM

are then operating via your vCenters 6, where all is nicely consolidated.

In this manner you avoid pitfalls and potential bugs and even save on supplemental work.

0 Kudos
depping
Leadership
Leadership

Sure you can do this, but I wouldn't recommend it for a longer period of time. I doubt this has been tested thoroughly and there's things like VMware Tools version and VM Hardware Version, Distributed Switch Version which are not cross host compatible potentially. It will definitely make operations a lot more challenging. And even some HA functionality may or may not work depending on the version of ESXi you are using. I would recommend to create 2 clusters in this case and separate based on the version/hardware.

0 Kudos
asajm
Expert
Expert

Hi Paul90

If you mean VM vMotion between 5.5 and 6.0 hosts. that is supported

But make sure that the VM's running on 6.0 is having hardware 10 ( don't upgrade the hardware version to 11 which is the compatible version for 6.0)

Also, don't enable the new feature of 6.0 ESXi on VM's.

If you think your queries have been answered
Marking this response as "Solution " or "Kudo"
ASAJM
0 Kudos