meoli
Enthusiast
Enthusiast

logfilter for Thermal interrupt in vmkernel not working

Hey there,

so i'm troubleshooting something in the vmkernel log on my laptop with ESXi 6.7 U2. But the vmkernel.log is getting spammed with:

2019-05-24T22:23:40.081Z cpu1:2099203)WARNING: APIC: 898: Thermal interrupt on pcpu 1

2019-05-24T22:23:40.081Z cpu0:2097176)WARNING: APIC: 898: Thermal interrupt on pcpu 0

2019-05-24T22:23:40.081Z cpu2:2097676)WARNING: APIC: 898: Thermal interrupt on pcpu 2

2019-05-24T22:23:40.081Z cpu3:2097267)WARNING: APIC: 898: Thermal interrupt on pcpu 3

2019-05-24T22:23:40.081Z cpu6:2098606)WARNING: APIC: 898: Thermal interrupt on pcpu 6

2019-05-24T22:23:40.081Z cpu7:2097188)WARNING: APIC: 898: Thermal interrupt on pcpu 7

2019-05-24T22:23:40.081Z cpu5:2097688)WARNING: APIC: 898: Thermal interrupt on pcpu 5

2019-05-24T22:23:40.081Z cpu4:2097584)WARNING: APIC: 898: Thermal interrupt on pcpu 4

messages... Smiley Sad Therefore i wanted to use the logfilter to get this spam out of the way (as i don't know any other way to disable those messages)

in /etc/vmware/logfilters i added the following lines with vi at the end:

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 0

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 1

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 2

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 3

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 4

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 5

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 6

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 7

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 8

0 | vmkernel | WARNING: APIC: 898: Thermal interrupt on pcpu 9

then i added

enable_logfilters = true

in my /etc/vmsyslog.conf

and finally used esxcli system syslog reload

but my vmkernel still is getting full of those messages.

Going trough examples the ":" isn't a problem in the Reg Expression and since i added all pcpu numbers shouldn't it be enough?

0 Kudos
3 Replies
daphnissov
Immortal
Immortal

Therefore i wanted to use the logfilter to get this spam out of the way (as i don't know any other way to disable those messages)

Well, I've got an infinitely better solution for you...don't run ESXi on a laptop Smiley Happy

I have not ever tried to exclude log messages because it's generally a bad idea, however since you're in the business of bad ideas try to reduce the filter to only the following:

0 | vmkernel | Thermal interrupt on pcpu *

0 Kudos
meoli
Enthusiast
Enthusiast

Na, just giving up on running ESXi at on my laptop and trying to get the GPU-Passtrough working would be too easy Smiley Wink

A portabel Target for vSphere Replication as an offsite Backup would be just too awesome!

Unfortunately your line didn't stopped the spam either Smiley Sad

0 Kudos
daphnissov
Immortal
Immortal

A portabel Target for vSphere Replication as an offsite Backup would be just too awesome!

wat.png

0 Kudos