bug_juice
Contributor
Contributor

how to re-package with mkisofs

Jump to solution

Hi,

     I'm trying to build a bootable ESXi 5.0 with a static IP in it because i have subnets that do not have PXE available to them.  I've been able to do this with ESXi 4.1, but ESXi 5.0 does not seem to work.  On ESXi 5.0 at this point i just want  to mount the ESXi 5.0 ISO file, copy the  files out of  it, then package  it back up with mkisofs, but obviously  I'm doing something wrong with  mkisofs.  I've been doing the following:

  • mount -o loop /root/esxi.5.0.iso /mnt; cd /mnt
  • rsync -a /tmp; cd /tmp/mnt
    • mkisofs -l -J -R -r -T -o /tmp/newesxi.5.0.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table .
    • mount and boot from vmware workstation virtual cdrom

    When i try to boot this newesxi.5.0.iso file, I get to the grub menu ok,  then i see "/ata-pata.v00: file not found."  Any light anyone can shine on this would be appreciated.

    Thanks in advance.

    0 Kudos
    1 Solution

    Accepted Solutions
    continuum
    Immortal
    Immortal

    try mkisofs.exe from the cdrtools
    cdrtools can be found in google ...

    this command works here:

    bin\cdrtools\mkisofs.exe -quiet -l -no-iso-translate -sysid "" -A "esxi50-live" -V esxi50-live -c BOOT.CAT -b ISOLINUX.BIN -no-emul-boot -boot-load-size 4 -boot-info-table -input-charset utf-8  -o temp/esxi50-live.iso files-esxi50


    ________________________________________________
    Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
    I do not support Workstation 16 at this time ...

    View solution in original post

    0 Kudos
    4 Replies
    continuum
    Immortal
    Immortal

    on windows I use a similar command
    just with the additional option -input-charset utf-8

    are you sure your isolinux.cfg and boot.cfg are ok ?


    ________________________________________________
    Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
    I do not support Workstation 16 at this time ...

    0 Kudos
    bug_juice
    Contributor
    Contributor

    utf-8 doesn't seem to be an option with my "mkisofs" on my solaris server.  "mkisofs" kicked back some known charsets, but none of them look close to utf-8.

    As for my isolinux.cfg and boot.cfg, i'm not doing anything to them so i would think they should be ok.  All I'm trying to do at this point is just copy the contents out of the iso file and then build it back into an iso before i do anything.

    maybe i'll try this on windows or linux and see if mkisofs does something different there.

    0 Kudos
    continuum
    Immortal
    Immortal

    try mkisofs.exe from the cdrtools
    cdrtools can be found in google ...

    this command works here:

    bin\cdrtools\mkisofs.exe -quiet -l -no-iso-translate -sysid "" -A "esxi50-live" -V esxi50-live -c BOOT.CAT -b ISOLINUX.BIN -no-emul-boot -boot-load-size 4 -boot-info-table -input-charset utf-8  -o temp/esxi50-live.iso files-esxi50


    ________________________________________________
    Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
    I do not support Workstation 16 at this time ...

    0 Kudos
    bug_juice
    Contributor
    Contributor

    It was the "-no-iso-translate" that fixed it.

    Thanks !!!

    0 Kudos