Lotfi21325
Contributor
Contributor

error upgrading esxi 5.5 to 6.0 with command line esxcli

Hello,

I have a remote ESXi server which needs to be migrated from version 5.5 to version 6.0 using command line, and a version 6.0 depot (ESXi-6.0.0-2494585-standard-depot.zip)

My server is version VMware ESXi 5.5.0 build-2068190

Once i apply the command :

esxcli software vib update -d /vmfs/...../ESXi-6.0.0-2494585-standard-depot.zip

But i receive this message error:

[InstallationError]

There was an error checking file system on altbootbank, please see log for detail.

Please refer to the log file for more details.

When i check the /var/log/esxupdate.log i read these lines, which do not help too much:

2019-12-23T13:05:37Z esxupdate: root: INFO: Command = profile.setacceptance

2019-12-23T13:05:37Z esxupdate: root: INFO: Options = {}

2019-12-23T13:05:37Z esxupdate: BootBankInstaller.pyc: INFO: Unrecognized value "title=Loading VMware ESXi" in boot.cfg

2019-12-23T13:05:37Z esxupdate: vmware.runcommand: INFO: runcommand called with: args = '['/sbin/bootOption', '-rp']', outfile = 'None', returnoutput = 'True', timeout = '0.0'.

2019-12-23T13:05:37Z esxupdate: vmware.runcommand: INFO: runcommand called with: args = '['/sbin/bootOption', '-ro']', outfile = 'None', returnoutput = 'True', timeout = '0.0'.

2019-12-23T13:05:37Z esxupdate: imageprofile: INFO: Adding VIB VMware_locker_tools-light_5.5.0-2.33.2068190 to ImageProfile (Updated) ESXi-Customizer

2019-12-23T13:05:37Z esxupdate: vmware.runcommand: INFO: runcommand called with: args = '['/sbin/esxcfg-advcfg', '-U', 'host-acceptance-level', '-G']', outfile = 'None', returnoutput = 'True', timeout = '0.0'.

2019-12-23T13:05:37Z esxupdate: root: DEBUG: Finished execution of command = profile.setacceptance

2019-12-23T13:05:37Z esxupdate: root: DEBUG: Completed esxcli output, going to exit esxcli-softwareinternal

And in the /var/log/esxcli.log it says:

[root ERROR] update failed:  [InstallationError]

There was an error checking file system on altbootbank, please see log for detail.

Please refer to the log file for more details.

Can anyone help me in this problem please?

Thank you in advance.

0 Kudos
4 Replies
Lotfi21325
Contributor
Contributor

I would like to add, that i tried the solutions found on Internet talking about the /altbookbank partition, and none of them helped me.

0 Kudos
a_p_
Leadership
Leadership

You are going from one major version to another, i.e. this is an upgrade rather than an update/patch.

I usually do this using the appropriate Offline Bundle, which may need to be a vendor specific one, depending on your hardware.

The commands I use are similar to:

  1. esxcli software sources profile list -d /vmfs/volumes/datastore/folder/offline-bundle.zip
  2. esxcli software profile install -d /vmfs/volumes/datastore/folder/offline-bundle.zip -p <profilename> --ok-to-remove --dry-run

The first command will list available profiles in the offline bundle. The second command will run a test installation. If the command's output looks as expected, remove "--dry-run" from the command line to run the upgrade, and then type "reboot" to reboot the ESXi host.

André

0 Kudos
Lotfi21325
Contributor
Contributor

Hello

It is not working too, please take a look to the following screenshot:

I confirm that i need to use standard depot because the server is not from known vendor.

Is there anything that might resolve my problem please?

Thank you in advance;

esx-prs-error.PNG

0 Kudos
a_p_
Leadership
Leadership

I havn't experienced this issue myself, but there's a KB article with instructions to fix this.

see https://kb.vmware.com/s/article/2033564

André

0 Kudos