Tippet
Contributor
Contributor

cli upgrade to 5.5 - error invalid

trying to upgrade to the latest version 5.5 using putty/cli

esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml –profile=ESXi-6.0.0-20150504001-standard

Error: Invalid option –profile=ESXi-5.5.0-20160904001-standard
0 Kudos
1 Reply
a_p_
Leadership
Leadership

What you posted doesn't seem to really match!? You're saying that you're trying to upgrade to the latest v5.5 profile, but the command contains a v6.0 profile, and the error message is about v5.5 which hasn't been specified!? In addition to this, it also seems that the command was copied from an application with an auto correct feature, which replaced the dash (in front of "profile") to a special character.

Anyway try:

esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-5.5.0-20160904001-standard

André

PS: adding --dry-run to the command line will show you what's going to happen without installing anything.

0 Kudos