RZ112358
Contributor
Contributor

cim-diagnostic.sh - INFO: sfcbd is administratively disabled

Hello All,

I spent some time yesterday fighting with cim-diagnostic.sh and couldn't get it to work.  I was trying to track down some detailed info on the server memory, but cim-diagnostic.sh would only respond with:

[root@localhost:/tmp] cim-diagnostic.sh

INFO: sfcbd is administratively disabled

I couldn't find any config file or other location within the Web UI were I could "administratively enable" sfcbd so that the script would run.

The steps in this KB, as well as some other websites, were followed to make sure sfcbd was enabled (and it was):

How to disable the CIM agent on the ESX/ESXi host (1025757) | VMware KB

After finally taking a look at the script itself, it looks like it's searching for the string "enabled: false" in /etc/sfcb/sfcb.cfg.  This is located within the first few lines of the script.  However, after the grep command in the script, the condition on the if statement seems to be incorrect.

I made a copy of cim-diagnostic.sh in /tmp and changed the if statement to:

if [ "${DISABLED}" != "" ]; then

After that, the edited copy of the script was able to run successfully.

This was an HP ESXi host running the custom HP image: HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28

If I was missing something about running cim-diagnostic.sh or if there was a different way to address this, please let me know.

Thanks!

0 Kudos
1 Reply
kbiradar
Enthusiast
Enthusiast

Hi

sfcbd is by default turned off unless third party cim providers installed from 6.5 onward.

You can log into esxi using ssh and then run below command

'esxcli system wbem set -e 1' without quote.

Another way to enable sfcbd

'/etc/init.d/sfcbd-watchdog start'

but this is not recommended

0 Kudos